The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Joe Meek 6Q output issue
Old 6th September 2013
  #1
Gear Addict
 

Joe Meek 6Q output issue

I've had a Joe Meek 6Q for 4-5 years and it gets used on rare occasions. It's always been a fidgety piece of gear but recently I'm having a really weird issue. I plug a mic into it and I see that I'm getting gain and level from the meter on front but the the output seems to crap out and go completely silent at times. I've tried both XLR and 1/4" outputs and both have the same issue. I've trouble shot the thing again and again and for a while the fix was to simply peak the gain (it would suddenly "awaken" then and work) but the output is just [email protected]

I'm about to deep six the thing because it ruined probably a half dozen drum takes in the last month but curious if there's anywhere in the New York City area I might be able to take it to, to get looked at. I'd spend a hundred bucks or so to get it working properly because I do like its "color" when its actually up and running.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump