The No.1 Website for Pro Audio
Another Valve dilema!!
Old 4th June 2003
  #1
Gear Nut
 
neilsby's Avatar
 

Another Valve dilema!!

Hey there, i really need some help!

I purchased a TSL 60 about a month ago and it was running fine until today. I can get absolutely no noise from it at all. Upon further investigation i noticed that the heater for one of the output valves wasn't working. However when i replaced the valves with new ones the heater worked but there was still no sound.

Does anyone have any ideas what the problem could be, i'm desperate!

Thanks,

Neil.
Old 5th June 2003
  #2
One with big hooves
 
Jay Kahrs's Avatar
Could also be a fuse. The JCM900's have a fuse for each pair of output tubes. Might also be the output transformer, could be a cap...maybe a resistor. Could be a lotta things. Since it's a month old bring it to a service center and get it fixed under warrenty.

Also, a good rule of thumb to follow is that if you lose a tube for whatever reason shut the amp off fast and replace the tube or get it fixed. The longer you run an amp with a bad tube the higher the repair bill will be. If you lose the output tranny it's really freakin' expensive plus it's a huge part of the amps tone. It won't matter much with a TSL but a Plexi or simple amp like a Naylor will sound vastly different with a different ouput tranny.
Old 6th June 2003
  #3
Gear Nut
 
neilsby's Avatar
 

Thanks for the advice Jay, taking it back to the place of purchase for a straight swap, might be tempted by the mode four though! The new marshall solidstate amps. Anyone heard any good sounds from them?
Old 6th June 2003
  #4
Gear Maniac
 
scotty-o's Avatar
 

I just finished an album for a band a couple weeks ago and the guitar player brought a new Marshall Mode 4 w/ "matching" cab and his old JCM 800 with a 1960 cab..................
the 800 kicked the Mode four in the grillcloth and made it say "uncle"
I've never really liked solid state Marshall anything.
-Scotty
Old 7th June 2003
  #5
Gear Guru
 
Drumsound's Avatar
The store I'm quitting is a Marshall dealer. I played the MF the first day we got them. There are four channels/tones. One of them is kinda sorta useable... maybe.

Old 9th June 2003
  #6
One with big hooves
 
Jay Kahrs's Avatar
Marshall and solid state...nope. I haven't heard the Mode 4 but after recording too many Valvestate amps I'm not really going to go out of my way to hear it either. I'm also not a fan of the TSL amps, the DSL's are way more usable IMHO.
📝 Reply
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
♾️ Similar Threads
🎙️ View mentioned gear
Forum Jump
Forum Jump