The No.1 Website for Pro Audio
Problem with my Edirol FA-66-!!!READ QUICK!!!
Old 13th November 2009
  #1
Problem with my Edirol FA-66-!!!READ QUICK!!!

Alright, so I was letting a buddy try out the Edirol and he was planning on buying it today. Brought up something though.

He said the firewire cable stopped working and now the thing doesn't turn on.


He is a trustworthy christian guy, and I do not want to sell him broken stuff.

Anyone have ideas on what could be wrong?? I feel like I just wasted $220 because I used the damn thing a good 5 times...



Thanks,

-Ev
Old 13th November 2009
  #2
Lives for gear
 
Mark Kaufman's Avatar
 

Sure it's not the cable? And if it's buss-powered, a dead cable might prevent the unit from firing up...
Old 13th November 2009
  #3
Gear Maniac
 

is he using the powerplug, some pcs depending on the firewire chip have problems powering devices, tell him to use the power adapter and plug the firewire cable in.
Old 13th November 2009
  #4
would that do it?

I hope that is the problem, I am strapped on cash and could use this sale...

Can you buy any power cable for the device?

-Ev
📝 Reply
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
♾️ Similar Threads
🎙️ View mentioned gear
Forum Jump
Forum Jump