The No.1 Website for Pro Audio
Adam S2.5A Amp Rattle ??
Old 9th November 2009
  #1
Gear Addict
 
Jack Pettit's Avatar
 

Adam S2.5A Amp Rattle ??

One of my Adam S2.5A's has developed a rattle.

It's not coming from the speaker but from behind the cabinet.
It's on the other side of that big heat sink that screwed to the back of the cabinet.

Anyone have this problem?
Old 9th November 2009
  #2
Lives for gear
 
Bryce's Avatar
This sounds like a known problem that shows up in older S2.5As (and P22As)...which yours definitely are if they have heat sinks. This is a very bizarre problem that took a while to isolate and figure out how to fix.

There's an internal panel towards the back of the cabinet that separates the main body of the cabinet from the amp panel. During the assembly process, this panel should be slid into grooves inside the cabinet and then glued into place...but due to a manufacturing error the grooves are not there, so the panel is just held in place by glue. This glue can tend to dry out and crack over time, which allows air to pass through places it's not supposed to and results in cabinet rattle.

If this is what's causing your rattle, the unit needs to be disassembled so you can access the panel from both sides, and the glue around the panel needs to be cleaned up and reinforced using Gorilla glue and a syringe to get the glue in between the panel and the cabinet. It'll take a little while, but that should take care of the problem. You may want to do this to your other unit as well.

I don't know if that's what you're experiencing, but it sure sounds like it from your description and the fact that you have heat sinks definitely indicates older units...which are, of course, out of warranty.

If this is the problem, then this will hopefully save you a bunch of time and $ trying to get it sorted out...as I said, this one is kinda tough to pinpoint.

dB
Old 9th November 2009
  #3
Gear Addict
 
Jack Pettit's Avatar
 

Thanks Bryce,

Man I paid good money, for that amount of work to fix them.
Old 22nd November 2015
  #4
A very helpful thread and repairing this very problem on an older set of S2.5As; thanks Much, Bryce. The glue holding the port tube in place also dried up. Will post pics later.

Last edited by Harold LaRue; 22nd November 2015 at 09:26 PM.. Reason: Added thanks where due.
Old 23rd November 2015
  #5
Lives for gear
 
Bryce's Avatar
Quote:
Originally Posted by Harold LaRue View Post
A very helpful thread and repairing this very problem on an older set of S2.5As; thanks Much, Bryce.


dB
Old 23rd November 2015
  #6
Pics from Adam repair

Here are some images from the Adam S2.5A rattle repair. Enjoy!
Attached Thumbnails
Adam S2.5A  Amp Rattle ??-image.jpg  

Last edited by Harold LaRue; 23rd November 2015 at 03:50 PM.. Reason: More pics
Old 23rd November 2015
  #7
Dried Port Glue

More Pics
Attached Thumbnails
Adam S2.5A  Amp Rattle ??-image.jpg  
Old 18th February 2017
  #8
Gear Nut
 
parquix's Avatar
Geat info! Thx!
📝 Reply
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
♾️ Similar Threads
🎙️ View mentioned gear
Forum Jump
Forum Jump