The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Boss loop station issues
Old 6th September 2007
  #1
Gear Addict
 

Boss loop station issues

Hey all,

Wasn't sure whether to post this here or geekslutz or...

My Boss RC-20XL started acting wacky today. It made a loud 'pop' all of a sudden, so I killed all the power, unplugged everything and plugged it back in. When I turned the amp back on, I heard the loudest, most obnoxious noise I've ever heard. The tap tempo/guide LED is flickering from green to red really quickly, and my loops are seemingly lost. I'm also unable to record anything onto it. I thought I'd post to see if anyone has had similar issues with theirs, and if so, whether or not it's worth taking to a tech. Thanks in advance,

C
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
shikawkee / Gearslutz Secondhand Gear Classifieds
7

Forum Jump
Forum Jump