The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Fixing dodgy channels in my Mackie VLZ-1642 Modular Synthesizers
Old 4th September 2007
  #1
Lives for gear
 
jonnypowell's Avatar
 

Fixing dodgy channels in my Mackie VLZ-1642

Pretty much as soon as I bought my Mackie mixer a lot of the channels starting cutting in and out and then some stopped working at all.
It's def not a problem with any cables, I've ironed that out for sure.
Guessing it has something to do with dust in there.

So how do I go about fixing this myself? Do I need to open it up and use contact cleaner or something?

Cheers in advance,
Jonny
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
jonnypowell / Geekslutz forum
2
NineteenBillion / Geekslutz forum
11
rolo / Gearslutz Secondhand Gear Classifieds
0
tunefool / Low End Theory
8
simonv / So much gear, so little time
8

Forum Jump
Forum Jump