The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Input on ID14 not working
Old 20th June 2019
  #1
Gear Maniac
 

Input on ID14 not working

I have an Id14. I thought at first my tubes on my preamp before were going out because the sound cut in and out a couple times for no reason. But then I plugged directly into the ID14 and sure enough input 1 is completely out. The D.I or the mic input don't produce any sound. Input 2 still slightly works but it only goes up to the 2nd green light in level (very low) and when I turn the gain up it gets highly distorted...Its pretty much unworkable.

The outputs are fine. The controls are fine. Anyone know what might have happened? What I can do about it? thank you.
Old 20th June 2019
  #2
Gear Maniac
 

UPDATE: The 2nd input started cutting in and out as well. I then plugged back into 1 and it works like normal again. I've never had this happen before. I'm sure there is something wrong with them and I don't expect it to stay working if they were acting so strangely.
Old 21st June 2019
  #3
Lives for gear
 
TurboJets's Avatar
What a bummer. Hopefully you are still in the warranty period. Sounds to me like you should contact customer service at Audient.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump