The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Daking comp500 low input as channel insert?
Old 4th January 2018
  #1
Gear Head
 

Daking comp500 low input as channel insert?

Howdy friends. I have a couple of these in my 500 rack, they work great when I put them after a preamp on the way to tape, but when I try to insert them on a channel I can barely get the compression to kick in at all, even on very hot signals...it's weird.
I don't have this issue inserting anything else so I don't think it's an issue with my inserts. And the comps work fine as part of an input chain so I don't think there's anything wrong there. Anyone else had this issue? Usually I wind up inserting a preamp just to get enough heat to trigger the compression, but obviously don't feel I should have to do that.

One possible thing -
My insert points are unbalanced, going to a balanced patchbay, I've tried balanced and unbalanced patch cables to the Daking comp, same results either way though...

Thanks for sharing your experience or any suggestions!
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump