The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Broken Mackies. HELP!!!
Old 9th March 2017
  #1
Here for the gear
 

Broken Mackies. HELP!!!

Hi Everyone.

I have a pair of Mackies and the passive speaker has no sound coming out of it at all. The inside of the passive looks to be in good working order, no leaky caps or rust on the board etc. The powered speaker works. This suggests to me that whatever independently powers the passive speaker needs to be repaired or replaced. Any thoughts or info you can give me about solving this issue. Thanks

Kai
Old 10th March 2017
  #2
Here for the gear
I also have a pair of Mackies but never have had that problem. Make sure you have the red and black wires in their appropriate holes if that doesn't work i'd recommend getting new wiring as it has to do with that if the passive speakers aren't getting the power they need. Hopefully this helps!
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump