The No.1 Website for Pro Audio
Don't use Fishman Triple Play on Satin Finish
Old 3rd August 2020
  #1
Lives for gear
 
Rick Dalton's Avatar
Don't use Fishman Triple Play on Satin Finish

I was thinking back when I mounted the Triple Play on an Martin D28 Satin Spruce Top. I had used the clear magnetic mount, The TP worked halfazz on there, but I took it off and left the mount. It was on there for around 3 years, then I took it off and where the three magnets were located, there were three red dots in the wood. Some kind of reaction, looks like magic marker. Anyway, I contacted Fishman about it, as I was/am still pissed. Never got a response from them. Also contacted Martin, told them the deal and if their was some way to fix this. Never got a response from them ether. So just be aware that this looks to be permanent, and it was from the magnets and the satin finish. When I contacted both company's, it was to give a heads-up or warn people, but I guess they could care less.

Last edited by Rick Dalton; 3rd August 2020 at 11:22 PM.. Reason: added
📝 Reply
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump