View Single Post
Old 11th November 2009
  #1
Lives for gear
 

Will Logic 7.2 work If I install Snow Leopard?

Hi guys , I`m on a Mac Pro from 2008 , using Logic 7.2 and OS 10.4.9 (tiger).

If I install Snow Leopard , will I be able to install and use Logic 7.2 ?

Thanks!

Thomas