View Single Post
Old 20th May 2009
Lives for gear

Originally Posted by MatsonMusicBox View Post
  1. Ordered Waves bundles from Sweetwater along with this iLok thing I apparently needed. They sent my serial numbers and instructions for iLok usage/authorization.
  2. While waiting for the actual package, I went ahead and clicked the links to go "Register" the waves bundles - this required me to create an account at waves - no biggie, probably want one anyway, so I do. Registration goes smoothly enough.
  3. Now Waves want to "Send" my registrations to my "iLok account" ... OK .... I don't have an iLok account ... so I go there and create one ... fill out same tedious information .. .again.
  4. Go back to waves and "send" the registrations - indeed they show up in my iLok account after a few minutes ... cool ... but alas, I have no "registered iLok device" ... so I wait for FedEx
  5. Package arrives, I open iLok, plug it in to "Register it" ... but ... I have no "iLok client helper" software installed, so I have to download that to install it.
  6. But ... my office computer is my work computer, and I (re)learn via a nasty dialog that I can't install software on it because I don't have "administrative privileges" Arggghhhhhh!
  7. So - I kick the kid off the home computer - download the "helper app" there and install it, put in the iLok, but ... I have to now download and install a driver for the iLok!!!!
  8. Finally - I get the driver installed - go back to iLok web site and am able to "download" the authorizations onto the thing - a process itself that seemed inordinately long and confusing - but it worked.
  9. Now I'm off to the basement studio with my locked and loaded iLok to install waves.
  10. Let me interject here - Waves has the nicest software boxes and CD packages I have ever seen! No wonder it costs an arm and a leg - they have $100 in the darn package LOL!
  11. I install Waves - more or less smoothly, though it seemed to ignore where I told it to go and installed in its default directory - but it installed.
  12. Now I plug in iLock and ..... no driver! This despite the fact that it says "most software packages that need it will install it when they install themselves" - I have to go back upstairs and get a standalone driver installer from iLok and go back downstairs and install that.
  13. Do so ... and it works ... takes me a bit to point SONAR at the "right" waves directory - but get there and it all works ... yeah!
My point here is that I didn't really have anything go "wrong" and yet this was a huge pain in the rear - there has got to be an easier way. At least I think the next iLok bound software I buy will be much easier .... I think.

Well ... I bought another Waves package (JJP) a few weeks later, and to my dismay, it was even harder as I had to have some other piece of software to get the keys on the iLok for it as the "normal" method was not supported for that plug-in .... sorry, I don't remember the specifics here other than it took downloading and installing some separate piece of software.
First of all, I feel your pain. When I was building my current rig and shopping for plugins, I wanted to demo some of the waves stuff. After the first few sets of hoops, I just got pissed and refused to deal with it. Waves makes it difficult for the end users, no doubt about it.

Having said that, I own probably 40-50 different Ilok'd plugins and not once have I had any issues.

1. request a licence
2. Install plugins
3. download license.
4. get to work.

Maybe twice in 2 years I've had to update the ilok driver, which was a simple and painless procedure.

I don't mean to be a dick but IMO, you are making this a much bigger deal than it needs to be. I've never spent more than 10 minutes at a time dealing with ilok. I just can't understand why your experience has been so painful other than the fact that you're dealing with Waves.

Have you tried other companies Ilok'd products? If so, was it difficult or time consuming?