View Single Post
Old 1st July 2005
  #6
Gear Head
 
qoqo's Avatar
 

Quote:
Originally Posted by GPl
qoqo, are you still using x firewire? Is it now working(800)? Thanks for that firmware info though. I'm planning on a ad16x soon.
Hi Michael. If you're asking about the Rosetta 800, I can't say (though I've heard others who say that's working). The AD-16X and DA-16X are working with X-Firewire though (MacOSX 10.4.1 on a G5).

There is still one issue though, and I'm not sure if this is specific to CoreAudio. I described the issue in detail over at www.osxaudio.com, but that site is down right now. The problem happens when both AD-16X and DA-16X are used simultaneously (each on their own X-Firewire).

When an AD-16X is connected by itself, you will see (in Apples Audio/MIDI Setup, henceforth called AMS) 16 inputs numbered 1-16, and 2 outputs numbered 1-2.

When a DA-16X is connected by itself, you will see (in AMS) 16 outputs numbered 1-16, and 2 inputs numbered 1-2.

Now, if you connect both units, inputs 1-2 on the DA-16X conflict with inputs 1-2 on the AD-16X. The bottom line (for me) is that inputs 1-2 are not available on the AD-16X while the DA-16X is turned on.

After some discussion with Max, it turns out that these stereo in/outs can't be disabled (this would be the obvious solution) because CoreAudio can't deal with devices that have ONLY inputs, or ONLY outputs. So, I suggested that Apogee look into renumbering these in/outs in firmware from 1-2, to e.g. 17-18 (i.e. out of the range of the standard 1-16 numbering for the first 16 in/outs). It seems (from my layman's perspective) that this would remove the numbering ambiguity.