View Single Post
Old 3rd August 2020
  #154
CWL
Here for the gear
 

Quote:
Originally Posted by Neptune45 View Post
Hi, cheers for the detailed response. Softube definitely has to get on to this as there is definitely something wrong with their graphics.

Because I had the VST 2s working with non-OpenGL setting I haven't even risked opening a VST 3 since. I also decided to go ahead after demoing the offer for the 6 amps which they just had and buy them as I decided to have faith they will surely get this sorted out soon and I didn't want to miss out on the deal. At least they are working in VST 2 for me.

I have since seen the upgrade offer for Volume 4 at half price so downloaded all the plugins which I haven't got from them yet which are included in the Volume 4 bundle to demo. I only tried them in VST 2 for the above reasons. All but Summit Audio Grand Channel and other Summit Audio individual plugins and American Class A opened and worked. Didn't bother trying Parallels, Heartbeat, Modular or the Weiss MM-1 yet so don't know whether they will open properly as VST 2s.

Like I said, all the other plugins in the pack and my amp plugins and even Amp Room all now open in non-OpenGL mode (but slowly) however when opening the ones mentioned above which didn't work in VST 2 (haven't tried VST 3 for them either), it would just open a black blank screen where the plugin should be however I could change the presets and the plugin would sound ok, I just couldn't get the graphics to open up properly for it.

I am going to E-Mail Softube yet again as I don't really want to invest even more money, time and effort in their plugins if they aren't even going to address the fact that there is an issue and that they are somehow trying to fix it...

Edit: I am thinking I might like to get the bundle if they communicate with us properly about this issue however as there are some good plugins.

I download the majority of my updated drivers via my Motherboard's website (ASUS for me).

Lots of lessons learned here, thanks again for the consult. FYI mine seems to be working in OpenGL now too, although there doesn't seem to be any performance benefit, so I shut it back down. I too am going to follow up with Softube to hopefully benefit others and let them know they need to get it together.

The amps sound friggin awesome with the new cabs and Room IR module. It feels to me like they finally got something that was missing from all my other Marshall plugins.