View Single Post
Old 22nd June 2020
  #1
Here for the gear
 

Is my build too slow for 32 or 64 sample buffers

I built this machine mostly for cad and audio during quarantine but was surprised when I had everything setup that I was unable to run ableton sessions with software synths at 64 sample buffers (@44.1khz) without encountering cpu overrun crackles. I would have thought that this build would be total overkill for audio, what am I missing? I'm considering adding a amd gpu and going hackingtosh to try and see if it makes a difference (RT Longest Block variability), any suggestions?

Goal:
Lowest possible roundtrip latency while running 3-5 channels of various Software Instruments. I am running 2 external FX sends in a live setup so roundtrip latency is important for a couple reasons including reducing phase issues
Ideally I would run at 64 samples and 96khz which on the apollo 8p gives me a round trip latency of 2.5 ms, sadly omnisphere and lots of kontakt libraries are sampled at max 48 so I'm shooting for 48 @ 64 or 32 if possible.

Issue:
Crackles when playing lots of voices (quickly hitting 6 notes twice will cause a crackle almost every time with even just one instance of omnisphere and no other channels in session) Sometimes even crackles at 128 samples.

Attempted:
I have followed both the ableton and sweetwater windows 10 optimization guides
Initially I thought the OC and or turboboost feature could be causing issues with the audio driver by running cores with different clocks so tried disabling turboboost, OC, XMP, and different combinations of the above but still crackles.
Have tried unplugging everything but interface, plugging in just the apollo 8p on the different usb c slots and different thunderbolt adapters.
Playing omnisphere synth waveforms instead of sample patches makes no difference which I would think rules out any bottlenecks with the SSD's and therefore its a CPU issue. Have Diva so will confirm.
Wifi and all other programs are closed and nonessential services are stopped (Even No AV).

I want to be able to run the following VI's:
- 1x omnisphere (8 voice)
- 3x kontakt (6 voice)
- 1x arcade (4 voice)

Computer Specs:
- i9 9940x OC running 4.2 on all cores (boost off)
- (OS Drive) Optane 905p
- (Steam/Samples Drive) 970 Pro M2
- Asus Prime 299x deluxe II
- RTX2080ti
- CORSAIR 64GB 3600 XMP profile enabled
Audio Interface:
- ASUS usb C rear +> startech adapter +> Apollo 8p +> apollo twin via thunderbolt cascade

Connected USB Devices:
- Nord Stage 3
- Moog One
- Pioneer Toriaz sp16
- Vestax vcm 600
- Tbox 2x2 Midi I/O
- Analog Heat
- Ableton Push
Software:
- Ableton 10.14
- Windows 10 fully updated
- UAD 9.12.1