View Single Post
Old 14th September 2019
  #5509
Lives for gear
 

Quote:
Originally Posted by Randomized View Post
When triggering RD-8 pattern start via MIDI from Ableton and recording the output, the start of the recording is always ruined - it’s like RD-8 plays the first couple of steps two times with sight variations in timing, while rest of the loop is recorded properly. Any ideas why this happens?
Welcome to the wonderful world of MIDI drum machine synchronisation....

Assuming your audio recording setup is correct, did you try setting a count-in for recording? (right click on Ableton's metronome , I think)...

Also, in Ableton MIDI prefs, find the MIDI output for the RD-8 and adjust the clock offset to a negative value so that the RD-8 is in tight sync with Live's metronome. You can use a blank pattern on the RD8 with just a clave/rimshot sound on every 4th step, to get a metronome -like setup. Then adjust the clock offset in Live's prefs until they're both nicely in phase.

Another thing you can try is to lower your audio buffer size in Live's preferences , but of course this will increase CPU demands. The lower the buffer size, the tighter is Live's MIDI clock output... at least on the Mac, that is.