View Single Post
Old 13th March 2019
  #5
Gear Head
 

From the site: "Plugins require an iLok3."

Is this correct, no support for iLok2?