View Single Post
Old 2 weeks ago
  #52
Here for the gear
 

I was having this problem with my late 2018 Macbook Pro and Native Instruments USB audio interface, and this thread put me on the right track. It enabled me to consistently reproduce the issue by disabling and enabling "Set date and time automatically", even with all network interfaces inactivated.

The log in Console also confirmed that the dropouts only occurred in close proximity to com.apple.timed adjusting the clock.

Sadly, disabling "Set date and time automatically" and "Set time zone automatically" was not enough to stop com.apple.timed from running intermittently and setting the clock to the exact same time as before, triggering a kernel trap and reset of the sound engine.

However, the following does seem to have fixed the issue for me. I have had no dropouts, and the logs show no reset of the audio engine these last 24 hours.

I do not take any responsibility if this makes your mac explode.

Disable the com.apple.timed daemon

For this to work, you need to disable System Integrity Protection by running
Code:
csrutil disable
in Terminal in the Recovery OS (see the Apple documentation for details)

Then, back in regular macOS, run this command to disable timed:

Code:
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.timed.plist
If you decide you want to have automatic time adjustment again (when not doing audio work, or after Apple hopefully releases a fix), just replace unload with load in the above command.

If, using Console, you discover other daemons or agents doing something iffy that cause audio dropouts, an idea would be to make scripts to disable and enable these in one go, so that we can have trouble-free audio when doing audio work, but retain convenience of macOS when not.

Hope this helps someone!