View Single Post
Old 6th September 2018
  #25
Lives for gear
 
BezowinZ's Avatar
 

Quote:
Originally Posted by chucky3000 View Post
I guess, it's really as simple as I've described. After the kext is installed, the prompt to "allow" is pretty obvious.
It doesn't pop up as a system dialog box or anything. It's just some text with an "allow" button next to it in that system preferences panel.
iShowU Audio Capture not showing up – shinywhitebox help
I'll have him poke around one last time, but we had 4 eyes on this and couldn't find anything that even implied allowing permissions.

Going through some un/reinstallation of my own with MPC display driver just yesterday and seeing kext files, maybe a slightly more informed 2nd look will help. But I didn't have to allow anything related to the MPC software or driver. I'll check Security to see if anything is listed.

Quote:
Originally Posted by chucky3000 View Post
This doesn't make any sense. (I'm not attacking you, I'm saying that the computer and software are doing things that don't make sense.)

If the rack shows up as an option in audio preferences, and you can set your input to the rack in Logic, then it sounds like the kext is installed. Why you are getting no output is a mystery.
No input monitoring in Logic either, I assume?
Have you tried routing to a bus then set an aux track to the bus? (Just to see if the signal goes ANYwhere inside Logic...)
We were so focused on the kext file & allowing that we didn't experiment much, just made sure things were routed correctly. I will have him try some different routing.

Quote:
Originally Posted by chucky3000 View Post
I don't think it matters if the 002 is on or off, but in my case it was on and plugged in. I suspect Logic should NOT be running. But the worst that would happen is Logic might crash during the install.

It's also a mystery to me that you don't see the Avid kext in either of the Extensions folders, but the rack shows up as an input option.
All I can guess now is that there is something about your hardware (The mac Book) that is different from what I have here.

Sorry, but I'm out of ideas.
Good luck.
I believe his model is right before mine. I'll double check the location of my MPC kext files against his folders.

I'll likely be treating my brother to a new interface if a final round of trouble shooting isn't fruitful. Despite being 15+ years old, it's hard to let go. I had that unit Black Lion Audio modded. There are some decent pres in there.

Quote:
Originally Posted by chucky3000 View Post
Okay... maybe I'm not 100% out of ideas.
One thing that sometimes trips me up is that Logic obeys it's own rules for audio input and output. The settings under System Prefs -> Sound for input and output will only apply to audio the computer is making outside of Logic. So system sounds, audio in your web browser, games, movies...
You have to have the Logic Pro X -> Preferences -> Audio -> Devices set up right.
If you have the headphones plugged into the laptop and the audio is set up to output through the 002 Rack, you won't hear anything. Things like this can trip people up. Not sure if this is your issue or not.

If you're seeing levels on the input meter for a track but not the output... that's a big puzzle. I assume you tried to record on the input channel and got nothing?
My brother plugged into the laptop and my face lit up. I thought that was it... he didn't know to plug into the 002. Unfortunately, there was no sound out of the 002 headphone jack either.

But no, we did not try recording. With everything seeming to work aside from audio output, I was convinced it was the kext file & permissions, especially since it was the one topic of your suggestions I wasn't familiar with.

I'm going to do one more round of trouble shooting with him before I treat him to an interface. I may pass on my Clarett 4pre and upgrade to the 8pre. I'm considering some external summing with a Dangerous Music D-Box or similar. I'll need the outs.

Thanks again! Your time is greatly appreciated.