View Single Post
Old 9th April 2018
  #41
Quote:
Originally Posted by botw View Post
Thank you, thank you, thank you!

In our studio we have a brand new custom built PC that has hardly been able to run Pro Tools without error since we got it. This is a screaming Beast of a machine: Asus x299 Prime-A motherboard, Samsung EVO 850 SSD boot Drive, 64 gb of DDR4 RAM, an additional 1tb drive for audio and samples, Focusrite RedNet PCIeR card to interface with our RedNet gear, and a Universal Audio Apollo 8p. We could most of the time record okay at 2048 sample buffer size, but many times we would get random clicks and pops. Forget about recording at 64 samples. We also couldn't mix a 32 Channel session with more than a couple of plugins before the system usage meters went crazy, and stall the session out. We were resorting to mixing on our 2011Mac since it was stable.

As soon as I ran this file, tweaked for our 20 core system, I was able to run our sessions, and I don't have to worry about how many plugins are running anymore. I haven't tried recording at low buffer yet, but it looked pretty promising when I record enabled a few channels at 64 samples.

Is Pro Tools really written so badly for Windows that somebody has to come up with a hack like this just to make it work? I just don't understand why they can't put more R&D into it so that it just works. Not everybody has the kind of cash to step up to a Pro Tools HD or HDX rig. Again thanks to the OP for this fix, and the knowledge that you have shared!
I have a new Scan custom built audio PC, similar spec to yours, 18 cores. What I have found so far: I was surprised and a disappointed when testing the machine that I was seeing the cpu often ramping up all the way into the red and getting 9173 errors to deactive plugins. I work in post and so projects are well over 100 tracks with lots of plugins. However there was only a little performance increase because of these errors, over my previous 4core studio machine that it replaced, not good. This was all at 1024 buffer size, forget using anything smaller, it would only play for a few seconds before stopping. So i did more testing and I found that what was causing the problem were peripherals plugged into USB ports on boot up. The biggest problem for this was a UAD Octo. If I have the UAD switched on when I boot the machine then pro tools completely changes it’s cpu behaviour and the cpu runs wildly up and down from 20-100% and gives 9173 errors on playback. If I boot the machine and only after os is loaded then switch on the UAD the cpu behaviour is completely different. It’s super stable and sits around 20% and moves probably between 20-35%, no errors even under way more load with more effects added.
I have also found that if portable hardisks or other things plugged into the usb at boot up, similar patterns can emerge. I feel that it is something to do with the ASUS motherboard. The previous studio computer also had an ASUS board and I found that if Maschine was plugged into a USB port then the computer wouldn’t boot at all. I’m not sure if it is coincidence but it seems like a bit of a pattern to me, ASUS boards are temperamental with various usb devices attached at boot up. It could be there is a setting in the bios that would help, I haven’t tested or dug into looking into that as yet, but the only way for me to work so far is to switch on everything only after the os has loaded.

Just to note that the Octo needs to be switched off from cold boot. If at anytime the computer was booted with the Octo switched on, the only way to fix the cpu issues is to switch off all the power to the computer, then cold boot without the Octo switched on.