View Single Post
Old 25th January 2018
  #25
Lives for gear
 

Quote:
Originally Posted by KV626 View Post
It *IS* supported. Until 10.3.3
If you want to run 10.4 you have to install Sierra. Besides, I don't see a reason in january 2018 not to run Sierra. 10.12.6 is solid.
Because with every OS upgrade, incompatibilities arise. Incompatibilities disrupt workflow in a studio. Get it?? High Sierra has been a nightmare for audio until only recently.