View Single Post
Old 8th March 2016
  #1
Here for the gear
 

IGS Photon don't work with Kush Electra 500-series

A few weeks ago I bought a IGS Photon compressor. When I put in the lunchbox, it didn't seem to work. It didn't compress and the output was very loud. After sending it to IGS for repairs they could only tell that the Photon was 100% OK when it arrived.
After getting it back I started to rearrange and use different slots with the same result. But when it ran on its own with no other modules attached (or together with just the tubecore), it started to work. And it worked until I attached the Kush Electra EQs.
By attaching one, the compressing is reduced by half, and when attaching the other, the compression almost disappears. Note that the makeup gain is still active.

Made this video to make it a little more clear. The same loop is fed thru the tubecore and the photon, but only the photon is sent back to DAW.
The tubecore is for reference to show that it's not affected by the electras and I get the same result if the tubecore was disconnected.

I also notised when powering up the rack without the Kush attached, the GR lights lit up for a second on the Photon. When the Kushes are in place, they don't.

IGS can only say that there's nothing wrong with the Photon. Kush Audio support have not replied and the dealer I got the Photon from don't have a clue what's wrong.

Anyone???