The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Question regarding Reason 10 Performance
Old 12th April 2018
  #1
Here for the gear
 

Question regarding Reason 10 Performance

Hey guys, I recently just purchased Reason 10 as I used to this program a lot a couple years ago and I think it's fantastic for writing music however - from my memory of how it operated in the past, one of the key highlights I liked about it a lot is it was a solid piece of software - it was very lite on memory and CPU resources. Always easy to open up and work on even pretty massive projects, on a macbook with only dual core processors.

Fast forward to now, I'm on a newer iMac with an intel i5 quadcore processor if I'm not mistaken, and taking a look at the Activity Monitor app the moment I open up Reason 10 (the last iteration I was on was Reason 5, pretty sure) and immediately Im seeing big CPU spikes and can tell from the way the displays and the way things are operating that this is being a major performance hog right off the bat.

Is it because of the newer VST support? I just opened a blank project and loaded up a couple of simple effects to play around with and one instance of Absynth from NI.

If there are any "tips and tricks" so to speak for how to get optimal performance out of my Reason rig without having to break massive CPU budgets, I'd love to hear about it from anyone's personal experience with using it as of late.

Thanks a lot for reading!
Old 13th April 2018
  #2
Lives for gear
 

I can't answer mac, I'm sorry. but.......considering I came from version 8.3 to 10 I can say that on DOZE the performance is better. Quite better tbh.

Sorry again that we are of two different worlds, maybe mac isn't as tight? I don't know.
Old 13th April 2018
  #3
Lives for gear
 

I got a thing today that said something about performance issues with reason 10 on the latest high sierra.
Old 14th April 2018
  #4
Here for the gear
 

Quote:
Originally Posted by toowrongfoo View Post
I got a thing today that said something about performance issues with reason 10 on the latest high sierra.
That has to be it - I also foolishly realized I had my sample buffer rate set low as if for recording and increased the samples to around 1000 or so, which seemed to have helped marginally.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump