The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Free TC Electornic M30 Reverb! Hurry! It's only a 3 days promo... Reverb & Delay Plugins
Old 16th November 2009
  #31
Gear Maniac
 
Aux13's Avatar
G5, Logic 8... no go
Old 16th November 2009
  #32
Lives for gear
 
miro's Avatar
 

intel MBP..first ableton crashes. after second try it works (sometimes)
Old 16th November 2009
  #33
Gear Head
 
bumbum's Avatar
 

Quote:
Originally Posted by Aux13 View Post
G5, Logic 8... no go
same here
Old 16th November 2009
  #34
Gear Maniac
Peaks in Logic 8

I've put the reverb on an auxiliary track in wich I sent a guitar track.While I was scrolling presets it suddenly peaked to the roof(no sound,and just on the output meter) and just would'nt go down until I removed the plugin from the slot...sounds good but does'nt look usable,stable...
Old 16th November 2009
  #35
Lives for gear
 
3rdeyeKnight's Avatar
 

Downloaded. Thanks.
Old 16th November 2009
  #36
Gear Nut
 

Cubase 4.5 here no problems at all! About the sound i'm on low end headphones right now so won't make judgements. Waiting to get home and listen it on monitors. But my first impression is that this one sounds smoother more fluid and natural (not harsh) than most algo reverbs out there. i could be wrong though.. anyone else confirm this or not?
Old 16th November 2009
  #37
Lives for gear
Quote:
Originally Posted by cane creek View Post
Im pretty sure thats the plan , i feel this is just a little taster to grab your attention
Yep but no way I'd pay 80 bucks for this
Old 16th November 2009
  #38
Gear Head
 

Quote:
Originally Posted by futur2 View Post
i applaud the effort of a free plugin but i am always astonished that tc never seems to manage introducing something that "just works"
Exactly... from four years at least.
I am not installing anything from TC anymore - their software was able to corrupt entire system, which worked flawlessly beforehand
Old 16th November 2009
  #39
Lives for gear
Quote:
Originally Posted by Renan L.B View Post
But my first impression is that this one sounds smoother more fluid and natural (not harsh) than most algo reverbs out there...
Smooth and fluid yes. I'd still go with variverb pro when I want natural, but that maybe just because I got used to it.
Old 16th November 2009
  #40
Quote:
Originally Posted by cooker View Post
Yep but no way I'd pay 80 bucks for this
Being that I don't think this has ever existed before at any price I think they just pulled $80 out of a hat, really. They could have say $5, they could have said $1,000. Obviously it was designed to be a giveaway from the start... an "LE" style product to entice you into their world and get another mailing list address to spam you with.
Old 16th November 2009
  #41
Gear Nut
 

Could this be a sign of TC going native?
Old 16th November 2009
  #42
Works just fine on my MacBook Pro with Logic Pro 9.
Old 16th November 2009
  #43
Lives for gear
 
lordnielson's Avatar
 

SmoooooOOO0000OOOooooooth.
Old 16th November 2009
  #44
Jam
Lives for gear
 
Jam's Avatar
 

Quote:
Originally Posted by Cobber View Post
Works just fine on my MacBook Pro with Logic Pro 9.
Ditto

James
Old 16th November 2009
  #45
Gear Guru
 
Karloff70's Avatar
 

Quote:
Originally Posted by Siem View Post
thanks! It sounds great on vocals!
I don't understand why it permanently says "algorithm: hall" on the screen. It suggests you can change the algorithm.
That's cause the hook is sitting in your lip now that you like the Hall, so the ideal continuation is you buy some more TC gear that has Plates and Rooms .....lol

Thanks for the heads up!!
Old 16th November 2009
  #46
in Ableton after playing around with it I got a very loud shrieking sound and had to rip off my headphones...
Old 16th November 2009
  #47
Lives for gear
 
Solar's Avatar
 

Wayto go TC!!!

Just grabbed this and it's very nice free pluging and useful!

Add it on a mix working right now with acoustic Guits and man, very subtle and shine very well.

Most important very happy to see that TC is letting us know that Native versions are on the way!!!! thumbsup

Thanx for the headsup and thanx TC for taking the steps further more!!!
Old 16th November 2009
  #48
Lives for gear
Quote:
Originally Posted by terminal3 View Post
Being that I don't think this has ever existed before at any price. Obviously it was designed to be a giveaway from the start...
It's identical to the TCM40 reverb plugin which comes bundled with the Konnekt 6 audio interface, and as someone pointed out in this thread minus the room and plate algo's.
Old 16th November 2009
  #49
Lives for gear
 
Alxi's Avatar
 

thanks for the heads up !!

-Alxi
Old 16th November 2009
  #50
Quote:
Originally Posted by Alndln View Post
It's identical to the TCM40 reverb plugin which comes bundled with the Konnekt 6 audio interface, and as someone pointed out in this thread minus the room and plate algo's.
Yes, but my point is you can't purchase that plug-in separately either, it only comes with the interface, so the $79 price is somewhat arbitrary.
Old 16th November 2009
  #51
TZk
Gear Maniac
 

Logic 9.0.2. on a macbook pro.
The AU has a major bug. If you change settings it goes completely bezerk, meter in red and outputting digital gibberish...

Just using the knobs works but not going thru settings.
Old 16th November 2009
  #52
Lives for gear
 
danbronson's Avatar
 

Just downloaded it and tried it on female vocals, drum room mic and snare. I think it sounds good (very nice for free!). Worked best on the vox of course. Has a nice 'motion' in it but sounds a little thin and if the hi color goes above 0 it can be a little painful (I'm finding -25 and even a little lower is best for my applications). Not the most realistic reverb I've heard but certainly could be useful. I have Breverb and TC Fabrik R and think they sound a lot better.

It works fine for me (PC, Cubase 5) as long as it's on a send and set to 100% in the plugin (using DAW for wet/dry mix). Anything else and there are strange problems, I don't think it's reporting its delay compensation right.
Old 16th November 2009
  #53
Lives for gear
 
Red 7's Avatar
RTAS!!!!
Old 16th November 2009
  #54
Lives for gear
 

WARNING!!!! Use at own RISK!!!

For me it's working fine on the Mac Pro Quad - Logic 9.02 - OS X 10.6.1

Started playing around with a few patches Acoustic guitars (Omnisphere) and piano (Motif XS) but felt it was doing something to the sound so I ran a 1Khz sine into it panned hard left and set Pre-Delay: 0, Decay Time:.1 and Hi color: 0.
Both the Waves and Logic correlation meters show phase issues. Panning hard right returns the signal close to center.
Then I thought I 'd give some drums and loops a bash and changing a preset emitted nothing but an extremely loud burst of noise. So dfegad M30 Freebie...

This is not the first time I'm having hassles with TC's Plug-in Verbs either. As an owner of the Konnect 48 and the PowerCore I can't use my wonderful TC reverbs cause they are prone to weird digital noises.
Old 16th November 2009
  #55
Gear Maniac
 
marcpl's Avatar
 

Quote:
Originally Posted by Red 7 View Post
RTAS!!!!
it works just fine with the vst-rtas wrapper.
Old 16th November 2009
  #56
Anyone got this to work in Cubase 5.1?
Just wont show up in my plugin list here.

I can see the .dll file in the Vstplugins folder too..
Old 16th November 2009
  #57
Quote:
Originally Posted by Sonic Nomad View Post
Then I thought I 'd give some drums and loops a bash and changing a preset emitted nothing but an extremely loud burst of noise. So dfegad M30 Freebie...
I had this same problem - in OSX and Live
Old 16th November 2009
  #58
Lives for gear
 

Quote:
Originally Posted by SWAN808 View Post
I had this same problem - in OSX and Live
Question: Do you have any TC DSP reverbs on your system as well?
Old 16th November 2009
  #59
ValhallaDSP
 
seancostello's Avatar
 

Quote:
Originally Posted by Sonic Nomad View Post
Started playing around with a few patches Acoustic guitars (Omnisphere) and piano (Motif XS) but felt it was doing something to the sound so I ran a 1Khz sine into it panned hard left and set Pre-Delay: 0, Decay Time:.1 and Hi color: 0.
Both the Waves and Logic correlation meters show phase issues. Panning hard right returns the signal close to center.
It would be interesting to try this test with other reverbs. Most reverbs mess with phase a LOT, which will show up as correlation issues with a single sine wave. Try varying the frequency of the sine, and see how the correlation meter changes.
Old 16th November 2009
  #60
Lives for gear
 
Solar's Avatar
 

Quote:
Originally Posted by Ihsahn1981 View Post
Anyone got this to work in Cubase 5.1?
Just wont show up in my plugin list here.

I can see the .dll file in the Vstplugins folder too..
Works like a charm here, installed, launched C5.1 and boom add it on acst guist and rock on!

Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
kedbear / So much gear, so little time
12
sacha love / Gear free zone - shoot the breeze
0

Forum Jump
Forum Jump