Softube releases Amp Room and Marshall Cabinet Collection - Page 6 - Gearslutz
The No.1 Website for Pro Audio
Softube releases Amp Room and Marshall Cabinet Collection
Old 2nd August 2020
  #151
CWL
Here for the gear
 

Working ok for now...

Quote:
Originally Posted by Neptune45 View Post
Cheers. I will also report on this thread anything I find out about this situation. I hope you get it working as well. Oh and I checked and when updating everything, I updated to Windows 10 x64 OS Version 2004.
After disabling my AMD GPU altogether, on plugging in, all I got was clicks and pops.

More research...

Found a list of issues:
Error deep in Windows settings governing how and when updates are performed. It was basically fooling itself into thinking that v1909 was the latest version and telling me that I was up to date. Resolved that and updated to v2004.

Uninstalled AMD’s management software

Reset the PC

Installed latest version of AMD management software which is the only way to install the latest driver

Optimized OS for audio, reinstalled DAW and plugins, disabled Opengl in Amp Room

Plugged in - still massive clicking and popping - CPU only pushing 7% - still a graphics issue.

Examined integrated Intel graphics processor and puzzled by driver dated 2016 - tried an update from Device Manager and Windows reported that was the latest driver. No way.

Tried to download and install latest driver (dated July 2020) from Intel directly - Windows blocked the install, error message that Lenovo has an OEM driver installed preventing any updates. WTF?????

Found a workaround, got the latest driver installed.

Booted DAW and loaded Amp Room vst2 in non-Opengl - success.

It seems the problem was the integrated graphics driver, not necessarily the AMD. Performance still feels rickety - lots of spikes in my Time Load indicator in Cantabile - but it is functioning and reasonably stable enough for now.

This was a multi headed dragon, and I don't think Softube is blameless because none of my other plugins had this problem. Amp Room is just a hog, and there may not be any better explanation.
Old 2nd August 2020
  #152
Lives for gear
 

Quote:
Originally Posted by CWL View Post

This was a multi headed dragon, and I don't think Softube is blameless because none of my other plugins had this problem. Amp Room is just a hog, and there may not be any better explanation.
Hi, cheers for the detailed response. Softube definitely has to get on to this as there is definitely something wrong with their graphics.

Because I had the VST 2s working with non-OpenGL setting I haven't even risked opening a VST 3 since. I also decided to go ahead after demoing the offer for the 6 amps which they just had and buy them as I decided to have faith they will surely get this sorted out soon and I didn't want to miss out on the deal. At least they are working in VST 2 for me.

I have since seen the upgrade offer for Volume 4 at half price so downloaded all the plugins which I haven't got from them yet which are included in the Volume 4 bundle to demo. I only tried them in VST 2 for the above reasons. All but Summit Audio Grand Channel and other Summit Audio individual plugins and American Class A opened and worked. Didn't bother trying Parallels, Heartbeat, Modular or the Weiss MM-1 yet so don't know whether they will open properly as VST 2s.

Like I said, all the other plugins in the pack and my amp plugins and even Amp Room all now open in non-OpenGL mode (but slowly) however when opening the ones mentioned above which didn't work in VST 2 (haven't tried VST 3 for them either), it would just open a black blank screen where the plugin should be however I could change the presets and the plugin would sound ok, I just couldn't get the graphics to open up properly for it.

I am going to E-Mail Softube yet again as I don't really want to invest even more money, time and effort in their plugins if they aren't even going to address the fact that there is an issue and that they are somehow trying to fix it...

Edit: I am thinking I might like to get the bundle if they communicate with us properly about this issue however as there are some good plugins.

I download the majority of my updated drivers via my Motherboard's website (ASUS for me).
Old 3rd August 2020
  #153
Gear Guru
 
Jeezo's Avatar
Open gl unable , built in gpu as well as dedicated .... i do t think this is specifically a softube issue ... but hw acceleration optimisation , you guyz should observe the dpc latency when the amd process is on via latency mon , this will help ..
Old 3rd August 2020
  #154
CWL
Here for the gear
 

Quote:
Originally Posted by Neptune45 View Post
Hi, cheers for the detailed response. Softube definitely has to get on to this as there is definitely something wrong with their graphics.

Because I had the VST 2s working with non-OpenGL setting I haven't even risked opening a VST 3 since. I also decided to go ahead after demoing the offer for the 6 amps which they just had and buy them as I decided to have faith they will surely get this sorted out soon and I didn't want to miss out on the deal. At least they are working in VST 2 for me.

I have since seen the upgrade offer for Volume 4 at half price so downloaded all the plugins which I haven't got from them yet which are included in the Volume 4 bundle to demo. I only tried them in VST 2 for the above reasons. All but Summit Audio Grand Channel and other Summit Audio individual plugins and American Class A opened and worked. Didn't bother trying Parallels, Heartbeat, Modular or the Weiss MM-1 yet so don't know whether they will open properly as VST 2s.

Like I said, all the other plugins in the pack and my amp plugins and even Amp Room all now open in non-OpenGL mode (but slowly) however when opening the ones mentioned above which didn't work in VST 2 (haven't tried VST 3 for them either), it would just open a black blank screen where the plugin should be however I could change the presets and the plugin would sound ok, I just couldn't get the graphics to open up properly for it.

I am going to E-Mail Softube yet again as I don't really want to invest even more money, time and effort in their plugins if they aren't even going to address the fact that there is an issue and that they are somehow trying to fix it...

Edit: I am thinking I might like to get the bundle if they communicate with us properly about this issue however as there are some good plugins.

I download the majority of my updated drivers via my Motherboard's website (ASUS for me).

Lots of lessons learned here, thanks again for the consult. FYI mine seems to be working in OpenGL now too, although there doesn't seem to be any performance benefit, so I shut it back down. I too am going to follow up with Softube to hopefully benefit others and let them know they need to get it together.

The amps sound friggin awesome with the new cabs and Room IR module. It feels to me like they finally got something that was missing from all my other Marshall plugins.
Old 4th August 2020
  #155
Lives for gear
 

Quote:
Originally Posted by CWL View Post
After disabling my AMD GPU altogether, on plugging in, all I got was clicks and pops.

More research...

Found a list of issues:
Error deep in Windows settings governing how and when updates are performed. It was basically fooling itself into thinking that v1909 was the latest version and telling me that I was up to date. Resolved that and updated to v2004.

Uninstalled AMD’s management software

Reset the PC

Installed latest version of AMD management software which is the only way to install the latest driver

Optimized OS for audio, reinstalled DAW and plugins, disabled Opengl in Amp Room

Plugged in - still massive clicking and popping - CPU only pushing 7% - still a graphics issue.

Examined integrated Intel graphics processor and puzzled by driver dated 2016 - tried an update from Device Manager and Windows reported that was the latest driver. No way.

Tried to download and install latest driver (dated July 2020) from Intel directly - Windows blocked the install, error message that Lenovo has an OEM driver installed preventing any updates. WTF?????

Found a workaround, got the latest driver installed.

Booted DAW and loaded Amp Room vst2 in non-Opengl - success.

It seems the problem was the integrated graphics driver, not necessarily the AMD. Performance still feels rickety - lots of spikes in my Time Load indicator in Cantabile - but it is functioning and reasonably stable enough for now.

This was a multi headed dragon, and I don't think Softube is blameless because none of my other plugins had this problem. Amp Room is just a hog, and there may not be any better explanation.
Glad I’m on a Mac after reading this tale of
woe.
Old 4th August 2020
  #156
Quote:
Originally Posted by Dave Polich View Post
Glad I’m on a Mac after reading this tale of
woe.
Dont you start a Mac vs PC now.
Old 4th August 2020
  #157
CWL
Here for the gear
 

Quote:
Originally Posted by Dave Polich View Post
Glad I’m on a Mac after reading this tale of
woe.
I was a lifelong Mac user since late 80's. Finally decided last year that Apple wasn't a particularly great value anymore and switched to Windows. For the most part it's been fine, but this particular incident was atrocious - I was down for almost a month.

If this most recent round of diagnostics had not worked, I was going to bite the bullet and get a Mac. Apple's forthcoming development of their own processors (and I think GPU's, too?) is interesting, and once the developers have had a chance to get onboard, I'll probably switch back.

My experience with Apple wasn't especially wonderful over the years - I had some good computers and some turds. I didn't generally find them to be as reliable or well built as they're supposed to be. But the inhouse processors could be a game changer. Windows is by definition a patchwork of processes held together by duct tape, but I believe Mac OS is also more like that than Apple would care to admit!
Old 8th August 2020
  #158
Lives for gear
 
Pali's Avatar
 

If Softube launches a Bluetooth pedal with an expression pedal it would be great.
Old 16th August 2020
  #159
Lives for gear
 
nichttuntun's Avatar
 

@ Softube

Hi guys in general. I'm a bit confused by Softube while they are not reacting to a support ticket and meanwhile - after making 2 reminders - Im starting to get a bit frustrated too. It's been nearly two month now. Before starting something, I just want to have an opinion from you how you see the situation. Do they have problems to manage all the tickets due to Corona situation? Or may it be ignorance too? The stated in may 2020 they had actual problems solving all the requests. It's August by now.

I don't want to go into further detail yet, but the complete situation and the reason I wrote them is really annoying and I am not feeling they take me serious as a customer. I really hope it has a reasonable reason why this is like it is. Can you report about your experience in short words? Would be thankful. Thanks.
Old 16th August 2020
  #160
Gear Addict
The price/support ratio with softube is absolutely not acceptable. I once was a fan, but don't buy anymore from them due to the fantasy prices and because of fear the stuff stops working completely and I don't get support anymore.
It's already wonky on Windows due to the gui and openGL issues.
Old 16th August 2020
  #161
Lives for gear
 
nichttuntun's Avatar
 

Exactly this was my first thought. What's if I got a real serious license issue due to the fact they rely on that iLok system. This paired with a mediocre support mentality... Doesn't give one a good feeling. I spent so much money over the last month for Softube and I am registered there since years... Hmmm. They made a hilarious decision or mistake imo, when the new amps came out and only two days later they offered the bundle. 3 for two. I already spent the money on the single amps two days ago and that *strategy*, not offering the bundles the same day is like pulling customers legs. I still call it a mistake, not a real strategy. So I wrote them about that fact and waited 3 weeks for the first reminder and 3 further weeks for the second reminder. I'm a patient person in general, but having no answer - with a blown up softtube account - is not a nice thing to be confronted with. Especially not when working in customers business for myself for over 30 years now. I'm purely disappointed. Maybe they have too much to do and can't cope. Maybe there are Corona based problems. Giving customers no reaction is a no go imh.

What would you do in such a case? Thanks
Old 16th August 2020
  #162
Gear Addict
 
Durk Diggler's Avatar
 

Quote:
Originally Posted by nichttuntun View Post
What would you do in such a case? Thanks
My advice is to maintain your mental focus and thus make your decision(s) based on reason instead of becoming emotional and irrational. But as far as making a reasonable decision I do not have any advice and will leave it up to you.
Old 16th August 2020
  #163
Lives for gear
 
nichttuntun's Avatar
 

Quote:
Originally Posted by Durk Diggler View Post
My advice is to maintain your mental focus and thus make your decision(s) based on reason instead of becoming emotional and irrational. But as far as making a reasonable decision I do not have any advice and will leave it up to you.
That may be a ZEN mined answer. I appreciate that and bow to you
Old 17th August 2020
  #164
Lives for gear
 
Pali's Avatar
 

I can assign MIDI to everything but the bypass buttons on any device.
I’m on Studio One 5 and bypassing modules are not reported to automation either.
Is this happening on other DAWs also?
Old 2 weeks ago
  #165
Lives for gear
 

So exactly how would I load/route 3rd party 15" speaker irs with Amp Room if I buy Amp Room?

I own the 59 plexi and am going to buy the jmp and bluesbreaker during this weekend's unlock sale.

What's the deal with the totally separate softube marshall ca collection....any overlap on the including amp room marshall cabs? Any real good reason to buy the separate marshall cab collections? Soooo may 12" speakers in there and I personally never noticed the diff on real marshalls.
Old 2 weeks ago
  #166
Lives for gear
 
Shaggy2039's Avatar
I just upgraded to Amp Room for $29 because I wanted to try out the System 72 filter (which is very cool as a "pedal", btw). I started casually scrolling through presets and I actually really loved what I was hearing this time around whereas when I initially tried Amp Room I didn't really gel with it. I think it's because I wasn't trying out more subtle / ambient presets which is where I think it would get the most use for me.

I also love how it imported my American Channel EQ and compressor directly into it. Excited to keep exploring this now and might even think about getting more Marshall amps. Is there one that everyone seems to out of the bunch?
Old 2 weeks ago
  #167
Lives for gear
 
nichttuntun's Avatar
 

Awesome system

Graphical GUI performance can be far improved. It´s lagge and sloppy feeling.

Thanks for reminding me, that System72 is now integrated. I didn´t associate it with AmpRoom, only Modular.
Old 2 weeks ago
  #168
Lives for gear
 

Germanium compressor can't be called up in Amp Room. What's up with that?
Old 2 weeks ago
  #169
Gear Nut
 
yorgos's Avatar
 

Quote:
Originally Posted by thenoodle View Post
Germanium compressor can't be called up in Amp Room. What's up with that?
What gave you the idea that it would?
Old 2 weeks ago
  #170
Lives for gear
 

Quote:
Originally Posted by yorgos View Post
Quote:
Originally Posted by thenoodle View Post
Germanium compressor can't be called up in Amp Room. What's up with that?
What gave you the idea that it would?
Because softube has three paragraphs in the amp room promo page saying "hey, route vocals through this stuff too...no need to limit to guitars"

Not that I would...but they're the ones who said it....not me.

So, I'm looking at the console/outboard softube stuff that can plug into amp room....and germanium's not there.

That's.....what made me think it would.

No biggie, I can certainly route guitars through the germanium in the daw.

That one little trip-up though, did cause me to remove amp room from the shopping cart. I did though, buy some more of their cool stuff last night.

By the way, does amp room simply not have any 15" speakers? Soooooo many 12s in there.
Old 2 weeks ago
  #171
Gear Nut
 
yorgos's Avatar
 

Quote:
Originally Posted by thenoodle View Post
Because softube has three paragraphs in the amp room promo page saying "hey, route vocals through this stuff too...no need to limit to guitars"

Not that I would...but they're the ones who said it....not me.
You can have American Class A, Tube-Tech CL1B, Trident A-Range EQ and Tape in Amp Room. There are many other Softube plugins that are not Amp-Room ready including the Germanium Compressor. This does not mean that their claim is false. Amp Room can function as a channel strip.
Old 2 weeks ago
  #172
Lives for gear
 

Quote:
Originally Posted by Shaggy2039 View Post
I just upgraded to Amp Room for $29 because I wanted to try out the System 72 filter (which is very cool as a "pedal", btw). I started casually scrolling through presets and I actually really loved what I was hearing this time around whereas when I initially tried Amp Room I didn't really gel with it. I think it's because I wasn't trying out more subtle / ambient presets which is where I think it would get the most use for me.

I also love how it imported my American Channel EQ and compressor directly into it. Excited to keep exploring this now and might even think about getting more Marshall amps. Is there one that everyone seems to out of the bunch?
I have Amp Room, the Marshall Cabs and all the native amps by Softube. I absolutely love the Bluesbreaker but you can't go wrong with any of them imo. I would suggest demo them first though.

If you have experience dialling in decent sounds on real amps you will have no problems with these.

I prefer these to my Neural DSP ones even though they are great as well.
Old 2 weeks ago
  #173
Lives for gear
 

Quote:
Originally Posted by nichttuntun View Post
Awesome system

Graphical GUI performance can be far improved. It´s lagge and sloppy feeling.

Thanks for reminding me, that System72 is now integrated. I didn´t associate it with AmpRoom, only Modular.
Yeah the GUI's are super laggy and I have a powerful computer. I was getting all sorts of problems when using Amp Room in VST3 and have had to use VST 2 instead which works ok but still laggy with the GUI.
Old 2 weeks ago
  #174
Lives for gear
 
Shaggy2039's Avatar
Quote:
Originally Posted by Neptune45 View Post
I have Amp Room, the Marshall Cabs and all the native amps by Softube. I absolutely love the Bluesbreaker but you can't go wrong with any of them imo. I would suggest demo them first though.

If you have experience dialling in decent sounds on real amps you will have no problems with these.

I prefer these to my Neural DSP ones even though they are great as well.
I'll try em' out. I missed the sale so if I like something I'll grab them during the next big blowout they do which is very often.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 4593 views: 582676
Avatar for soundrage
soundrage 5 days ago
replies: 441 views: 85211
Avatar for Guitarjon
Guitarjon 16th November 2017
replies: 60 views: 14759
Avatar for bgood
bgood 24th June 2016
replies: 117 views: 10757
Avatar for fairchildren
fairchildren 1 hour ago
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump