The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Kazrog releases KClip 3 Dynamics Plugins
Old 14th April 2018
  #1
Lives for gear
 
Kazrog's Avatar
 

Software Kazrog releases KClip 3



Kazrog has released KClip 3, the latest version of the flagship mastering clipper and track saturator. KClip 3 is rewritten from the ground up, and adds EBU / LUFS metering, multiband operation, a new engine, low latency mode, and more new features and enhancements.

KClip 3 – New Features:
  • Multiband Processing – Use up to 4 different clipping modes (or none) split between 4 assignable bandwidth regions.
  • EBU metering (LUFS) – Target loudness optimization to the desired level and quickly make sure your mix is ready for streaming.
  • Resizable Window – Enhanced visualiser and metering expand to fit the desired window size.
  • New clipping modes – In addition to expanded controls for Smooth, Crisp, Tube and Tape from version 2, add extra saturation and bite with Germanium, Silicon, Broken Speaker, and Guitar Amp.
  • Threshold – A top user request for 48 dB of additional headroom and/or gain capability.
  • Mid/Side processing – Clip your mid and side signals separately for extra stereo imaging control.
  • Settings A/B comparison – And other workflow enhancements, such as expanded oversampling options, window settings recall, wet/dry on front panel, and more.
Old 14th April 2018
  #2
Gear Nut
 
Oni.'s Avatar
Old 14th April 2018
  #3
Gear Maniac
 
JamesOnFlames's Avatar
It is SO good.

Multiband features are really great - love the ability to switch clipping types on the different bands. New types opens up more creative possibilities - have been hammering out NiNesque drums with the 'silicon' setting.

Loud loud loud masters with minimal tweaking.

This thing is a no-brainer. Buy it!
Old 14th April 2018
  #4
Lives for gear
 

First: wow
Second:upgrade path?
Old 14th April 2018
  #5
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by David Ray View Post
First: wow
Second:upgrade path?
Thanks! Upgrade coupons are on the product page.
Old 14th April 2018
  #6
Lives for gear
 
bitman's Avatar
No Kiddin?

Cool man.
This is the clipper to rule all clippers. Now with lufs metering? Oh jump around!
Old 14th April 2018
  #7
Lives for gear
 
bitman's Avatar
Oh crap though. Now it's expensive! 99.00!

What's with plug mfrs now wanting a kings ransom when last year they were cool?
Old 14th April 2018
  #8
Gear Head
 

Congratulations on the release Shane!

I think the pricing is more than fair as per the usual. This looks great.

Ill probably hold off on upgrading from pro2 but im sure ill pick it up once im finishing up my next mix.

Good stuff.
Old 14th April 2018
  #9
Lives for gear
Quote:
Originally Posted by JamesOnFlames View Post
It is SO good.

This thing is a no-brainer. Buy it!
I bought it already in September of last year! that's how no brainer it is. It has been worth the wait although I was surprised to see the pricing is still exactly the same as it was on my preorder back then.
Old 14th April 2018
  #10
Gear Nut
 
RobFish's Avatar
 

Fantastic Release!

Love the new modes, Multiband Features are awesome & I really dig the ew gui!
Old 14th April 2018
  #11
Lives for gear
 

It's very good !
Old 14th April 2018
  #12
Gear Head
 

click issue

Getting loads of clicks in multi-band, fine in single band. Logic X / 10.12.6.
New project, 2 tracks, no cpu spike.
Old 14th April 2018
  #13
Lives for gear
 
Jpga's Avatar
 

Quote:
Originally Posted by greenroom View Post
Getting loads of clicks in multi-band, fine in single band. Logic X / 10.12.6.
New project, 2 tracks, no cpu spike.
The same problem here and when I change the quality from 3 to 1,2,4,5 makes it sound very bad ! Kclip3 also gets the graphic lagg in Logic Pro X 10.3. OSX El Capitan.

I’m going to try how the lovely clipper behave in ableton live!
The Kclip pro 2 is flawless on my setup!

Last edited by Jpga; 15th April 2018 at 12:21 AM..
Old 14th April 2018
  #14
Lives for gear
 

It gets noisy and distorted in Multiband mode on OS X Sierra even with all bands bypassed
Old 14th April 2018
  #15
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by Jpga View Post
The same problem here and when I change the quality from 3 to 1,2,4,5 that makes it sound very bad ! Kclip3 also gets the graphics lagg in Logic Pro X 10.3 to layer. OSX El Capitan.

I’m going to try how the lovely clipper behave in ableton live!
The Kclip pro 2 is flawless on my setup!
1.) Stop and restart playback after changing quality.

2.) If you're having dropout issues, try a lower KClip quality setting, and/or a higher host buffer setting. KClip will always render offline at max quality - so the quality slider is there to alleviate realtime performance issues. Make sure you have Eco enabled for the best low latency performance and CPU efficiency.

3.) I will be adding preferences for the visualiser and meter refresh rates in the next minor update (as well as the ability to enable/disable all animation in the plugin window.)
Old 14th April 2018
  #16
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by ZangTumblyTumble View Post
It gets noisy and distorted in Multiband mode on OS X Sierra even with all bands bypassed
See my performance tips in the above post.
Old 14th April 2018
  #17
Gear Addict
 

Really miss the before/after visualization. That was what really set kclip2 apart from other clippers to me.
Old 14th April 2018
  #18
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by zachaction View Post
Really miss the before/after visualization. That was what really set kclip2 apart from other clippers to me.
The new visualiser is still a work in progress. Sorry about that!
Old 14th April 2018
  #19
Here for the gear
 

Is there a difference between the clipping in Kclip2 and 3 for example if just using Smooth mode with one band (with no parameters changed)?

Where is the option for 256X Offline oversampling?

Also, the delta function doesn't seem to work for Broken Speaker mode.
Old 14th April 2018
  #20
Gear Maniac
 

Still waiting on them to fix the phasing issues in their amps wet/dry knob. Once thats fixed I may buy this kclip update.
Old 15th April 2018
  #21
M2E
Lives for gear
 
M2E's Avatar
 

Quote:
Originally Posted by schmeete View Post
I bought it already in September of last year! that's how no brainer it is. It has been worth the wait although I was surprised to see the pricing is still exactly the same as it was on my preorder back then.
Yeah, me too. I thought that was a no brainer.
The only thing close to it is Clipper from Boz. Boz to me is a little fuller sounding and very low on cpu.
I'm hoping a few things will be updated.

1. Resize plugin. Man this thing is huge. I love that I can make it bigger but, the smallest size is way to big.

2. Hide the Visualizer.

3. What Oversampling is 2, 3, 4, 5 ,6?

Other than that, were good. Love it.

Marc
Old 15th April 2018
  #22
Lives for gear
 
Jpga's Avatar
 

No glitch when change the quality noob in 1 band funktion on Ableton.
In test the Kclip-2 Pro sounds fuller when push hard!
Please fix this,,,, we want the Kclip-3 sound better.
Old 15th April 2018
  #23
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by MacDonaldSound View Post
Is there a difference between the clipping in Kclip2 and 3 for example if just using Smooth mode with one band (with no parameters changed)?

Where is the option for 256X Offline oversampling?

Also, the delta function doesn't seem to work for Broken Speaker mode.
1.) No difference.

2.) It's gone, as it's not necessary. Oversampling with a good filter is diminishing returns after 32x. KClip 3 always bounces offline at 32x max quality.

3.) Will look into it.
Old 15th April 2018
  #24
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by mchillak View Post
Still waiting on them to fix the phasing issues in their amps wet/dry knob. Once thats fixed I may buy this kclip update.
Sorry for the long wait with that. Thermionik is next to see an update.
Old 15th April 2018
  #25
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by Jpga View Post
In test the Kclip-2 Pro sounds fuller when push hard!
Please fix this,,,, we want the Kclip-3 sound better.
It's the same algorithms for all modes from KClip 2 that are in KClip 3. There should be zero audible difference if you're matching settings.
Old 15th April 2018
  #26
Lives for gear
 
Jpga's Avatar
 

Add the same beat to 2 tracks, put on link mode and increase the in channel just before it distorts the base on the beat in both Kclip-2 and 3. Put the same output volym to them and listning. Is it same?
Old 15th April 2018
  #27
Lives for gear
 
Jpga's Avatar
 

I will not argue with you but I feel that Kclip2 Pro sounds better.
Old 15th April 2018
  #28
Lives for gear
 
Kazrog's Avatar
 

Quote:
Originally Posted by Jpga View Post
Add the same beat to 2 tracks, put on link mode and increase the in channel just before it distorts the base on the beat in both Kclip-2 and 3. Put the same output volym to them and listning. Is it same?
You be the judge - blind. I did exactly as you described with a cheesy retrowave drum beat I have. One of these clips is KClip 2, and one of them is KClip 3.

Dropbox - KClip_Blind_Test.rar
Old 15th April 2018
  #29
Gear Head
 

Quote:
Originally Posted by Kazrog View Post
See my performance tips in the above post.
tried all of this -- still getting constant buzzing clicks in multi-band,
has been unusable since I installed. it doesn't seem to be a performance issue - not getting any system warnings as is usually the case w/ Logic.
Old 15th April 2018
  #30
Quote:
Originally Posted by greenroom View Post
tried all of this -- still getting constant buzzing clicks in multi-band,
has been unusable since I installed. it doesn't seem to be a performance issue - not getting any system warnings as is usually the case w/ Logic.
I can replicate the issue here - it is related to the Quality setting:

macOS Sierra 10.12.6
Logic Pro X 10.4.1
Sample rate 96 kHz

Selecting multi-band (4) with a Quality setting above 1, regardless of Eco setting, results in sharp digital clicking. With Quality set to 1 the artifacts are not present.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump