The No.1 Website for Pro Audio
Antelope Goliath
Old 9th July 2019
  #511
Gear Addict
 

For me, it's the least stable interface I've ever owned. The IO is uncomparable. But if I had a similar option from a company like UAD and at a similar price point, I probably would go that route. I'm still thinking about switching out interfaces. I don't really have time for trouble shooting with Antelope, which BTW in past experiences was profoundly inefficient. Over several days, I had to take several hours to let them remote in. Each time, they reinvented the wheel, as if one person had not communicated with the other. All to confirm that the TB on my interface was toast within a month of owning it. I dread having to do it again, but the crashing and having to restart everything so that the interface is recognized may just make me go through it again.
Old 10th July 2019
  #512
Lives for gear
 
Squawk's Avatar
Mine has still been running smoothly here (Goliath HD) since the bugs were resolved. I’m only running it over MADI though on OSX with an RME MADIface XT as the primary interface. USB for the software control. Works great, and the features and I/O are hard to beat. I have no idea how well audio works over USB or Thunderbolt.
Old 10th July 2019
  #513
Lives for gear
 
I.R.Baboon's Avatar
Quote:
Originally Posted by Squawk View Post
Mine has still been running smoothly here (Goliath HD) since the bugs were resolved. I’m only running it over MADI though on OSX with an RME MADIface XT as the primary interface. USB for the software control. Works great, and the features and I/O are hard to beat. I have no idea how well audio works over USB or Thunderbolt.
Yup, similar set-up here (RME HDSPe MADI), i suspect you'll get the best mileage using it with an RME MADI soundcard / interface.........
Old 11th July 2019
  #514
Gear Addict
 

Yeah.... to me that defeats the purpose. I bought it as an interface, not solely for the converters. If I need another expensive piece of equipment in between the Goliath and the computer for stability it certainly doesn't seem worth it to me. I'm curious if this is the most common use for the Goliath around here.
Old 11th July 2019
  #515
Gear Maniac
I would be using everything it has to offer...

This all reminds me of 2 pieces of HW I have. Focusrite Liquidmix 32 & M-Audio Lightbridge. Both units are really picky with the other HW in the setup and still need special tricks to perform. And they were not that expensive but still I feel bad about the investment though they kinda work.
Old 11th July 2019
  #516
Lives for gear
 
Squawk's Avatar
Quote:
Originally Posted by I.R.Baboon View Post
Yup, similar set-up here (RME HDSPe MADI), i suspect you'll get the best mileage using it with an RME MADI soundcard / interface.........
For me, for sure. I’m on a 2012 Mac Pro tower, no Thunderbolt, no USB 3. So MADI was the best option.
Old 11th July 2019
  #517
Company Rep
 
Sam Antelope Audio's Avatar
 

Quote:
Originally Posted by Squawk View Post
Mine has still been running smoothly here (Goliath HD) since the bugs were resolved. I’m only running it over MADI though on OSX with an RME MADIface XT as the primary interface. USB for the software control. Works great, and the features and I/O are hard to beat. I have no idea how well audio works over USB or Thunderbolt.
Hi!

Indeed, you provided us with countless feedback for your experience and the issues that you had. We greatly appreciate your patience and positivity. We do believe that providing us with constructive feedback is key.

As @ I.R.Baboon said, this is a computer, a complex one at the same time, since it uses an FPGA chip, which cannot be compared to a DSP. The programming is far more complex and the behaviour of the chip as well, that of course introduces some bugs that we cannot catch by ourselves even if we do all of the testing in the world, because some bugs that might be there, only show up in specific setups. But we can find a solution to them and discover them through you, that's why it's essential to provide us with feedback as you did and as you saw - we did fix them.

I want to point out that with the newest generation of our units, we have taken the great base that we already have with our FPGA structure, thanks to guys like you and our amazing programmers, where issues like that are non-existent.

Thank you again for your support and if any of you guys need our help - message me or get in touch with our support team.
Old 11th July 2019
  #518
Lives for gear
 
I.R.Baboon's Avatar
Quote:
Originally Posted by Squawk View Post
For me, for sure. I’m on a 2012 Mac Pro tower, no Thunderbolt, no USB 3. So MADI was the best option.
And the funny thing is, with that "old" system, you'll probably get lower latency than TB or USB on a new machine!
Old 11th July 2019
  #519
Lives for gear
 
Squawk's Avatar
Quote:
Originally Posted by I.R.Baboon View Post
And the funny thing is, with that "old" system, you'll probably get lower latency than TB or USB on a new machine!
Well, to be perfectly honest, I'm running sessions at 96k and 32 bit float for the most part, and it's pushing that old machine pretty heavily for production and mixing work and it's a 12 core Xeon with 64GB ram.

My buffer setting with the MADIface XT is usually set at 2048, the maximum, unless it's a new session and I'm using VI's. Eventually though, that buffer ends up at 2048.

What I do love about the Goliath HD is the ease and flexibility for setting up direct monitoring while tracking. The other thing I'm finding extremely useful is the FPGA effects on my returning 2 buss path. I sum out to an SSL Sigma, then from there through various stereo hardware processors, then back into the Goliath via a Mytek Brooklyn AD. From there, it goes through the FX path of the Goliath, then back out to the daw via MADI to a stereo track for the final capture. I am not able to use AFX to DAW because I'm not using USB or TB, but this is still a good workflow for me. Normally I'm using the FPGA tape simulator plugin there, and it sounds great.

Now when the new Mac Pro becomes available in the fall, that's a whole different ball game, but tickets are expensive!
Old 11th July 2019
  #520
Lives for gear
 
Squawk's Avatar
Quote:
Originally Posted by Sam Antelope Audio View Post
Hi!

Indeed, you provided us with countless feedback for your experience and the issues that you had. We greatly appreciate your patience and positivity. We do believe that providing us with constructive feedback is key.

As @ I.R.Baboon said, this is a computer, a complex one at the same time, since it uses an FPGA chip, which cannot be compared to a DSP. The programming is far more complex and the behaviour of the chip as well, that of course introduces some bugs that we cannot catch by ourselves even if we do all of the testing in the world, because some bugs that might be there, only show up in specific setups. But we can find a solution to them and discover them through you, that's why it's essential to provide us with feedback as you did and as you saw - we did fix them.

I want to point out that with the newest generation of our units, we have taken the great base that we already have with our FPGA structure, thanks to guys like you and our amazing programmers, where issues like that are non-existent.

Thank you again for your support and if any of you guys need our help - message me or get in touch with our support team.

Hi Sam,

Thanks for the response.

I'm finding the FPGA effects to be very useful for 2 buss and "quick/home mastering" type scenarios. I'd love to see more plugins geared to this if at all possible. Something like the SPL Iron plugin for example, with M/S and stereo field editing would be really useful.
Old 14th August 2019
  #521
Lives for gear
 
I.R.Baboon's Avatar
Hi folks,

I'm sure this must be possible on my Antelope Goliath........but i can't quite seem to work it out!

Here's the Scenario:

In AFX slot 1&2 (stereo linked) i have two compressors and two EQs, tweaked to taste.

Now, i want to copy that exact same chain of 4 plugs (including their current settings) to slots 3&4.

Why? ........... 'cause, that's why!

But i can't work out how to do this.

Anyone? Is it actually possible? And if so, how?

Thanking you...........
Old 21st August 2019
  #522
Gear Head
Quote:
Originally Posted by I.R.Baboon View Post
Hi folks,

I'm sure this must be possible on my Antelope Goliath........but i can't quite seem to work it out!

Here's the Scenario:

In AFX slot 1&2 (stereo linked) i have two compressors and two EQs, tweaked to taste.

Now, i want to copy that exact same chain of 4 plugs (including their current settings) to slots 3&4.

Why? ........... 'cause, that's why!

But i can't work out how to do this.

Anyone? Is it actually possible? And if so, how?

Thanking you...........
Once saved you'd
Load it up
Check the AFX you want to copy
Select the tracks you want to copy to via the drop down

But guess what? this doesn't work on my GHD. R U Surprised?
Old 25th August 2019
  #523
Here for the gear
 

Hi! The Control Panel 'Effects' tab lets you save and load FX chains. Save your chain and load it onto channels 3 & 4. Write back/PM me if you can't get that sorted.
Old 29th August 2019
  #524
Lives for gear
 
I.R.Baboon's Avatar
Thanks guys, will try that.

You know one thing i'm really missing on the Antelope interfaces? A good level meter AFX plugin.

Here's the scenario: i run my mix out of Cubase and through an AFX compressor, which i love the sound of. And then out via AES/EBU to my monitor D/A.


But what's my level? Am i clipping a little? A lot? A really good, accurate meter plugin that i could insert after my compressor would be very useful.

The best kind of meter would actually be a moving waveform display like you see in Fabfilter L2. Because with that you can even see if it's saturating or not. Because it seems that when i crank the comp it sounds really cool. But is it saturating? Or am i just being deceived by level increase?
Old 9th November 2019
  #525
Lives for gear
 
Squawk's Avatar
Hi @ Antelope Audio ,

Why is it with the latest launcher update that my Goliath HD is no longer recognized? Each time I boot up I have to physically unplug the usb cable and plug it back in again. Major PITA...
Old 9th November 2019
  #526
Gear Addict
 

So I posted earlier that my Goliath was dropping the connection with Live (Thunderbolt) over the past several months. Since yesterday, it was only recognized as a 32/32 interface, though TB was recognized. Today my Mac Pro will recognize the interface, but the Launcher won't connect. Works fine over USB. I've owned my Goliath since April of 2018. Within a month or two I had to replace it because the TB port crapped out. Now I'm facing the same thing I suspect. I'm reaching out to Antelope right now. I sucked up the dropped connection for this long because I really don't have time to spend an hour on the phone with them over this, particularly during the work week. Anyone else have these issues? I feel like I probably should have stuck with my Apollos.
Old 4 weeks ago
  #527
Gear Maniac
Quote:
Originally Posted by Sinamsis View Post
So I posted earlier that my Goliath was dropping the connection with Live (Thunderbolt) over the past several months. Since yesterday, it was only recognized as a 32/32 interface, though TB was recognized. Today my Mac Pro will recognize the interface, but the Launcher won't connect. Works fine over USB. I've owned my Goliath since April of 2018. Within a month or two I had to replace it because the TB port crapped out. Now I'm facing the same thing I suspect. I'm reaching out to Antelope right now. I sucked up the dropped connection for this long because I really don't have time to spend an hour on the phone with them over this, particularly during the work week. Anyone else have these issues? I feel like I probably should have stuck with my Apollos.
They have also Live chat ans ticketing system! Just leave them a message.
Old 4 weeks ago
  #528
Gear Addict
 

Quote:
Originally Posted by alexiliev83 View Post
They have also Live chat ans ticketing system! Just leave them a message.
I have and I'm waiting to set up a time where they can remote in... the problem is being available, my time is very limited and this just takes away any time I would have had to make music.
Old 4 weeks ago
  #529
Lives for gear
 
Squawk's Avatar
Quote:
Originally Posted by Squawk View Post
Hi @ Antelope Audio ,

Why is it with the latest launcher update that my Goliath HD is no longer recognized? Each time I boot up I have to physically unplug the usb cable and plug it back in again. Major PITA...
Figured it out. Just had to allow remote connections again in the launcher settings to get it to work.
Old 4 weeks ago
  #530
Gear Addict
 

Just an update to my problem, I was able to get in touch with support. They remoted in and solved the problem. To be honest, I'm not quite sure what happened or how they fixed it. I think it was related to the AFX in some way. But the interface again shows up as 64/64. I haven't had time to test it out but I think all is good, and support was actually pretty responsive and incredibly helpful. I will note that this time I called in and had them on the phone, which I do think helped facilitate communication and improve the over all efficiency of the exchange, and the experience as a whole.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump