Gearslutz

Gearslutz (https://www.gearslutz.com/board/)
-   High End (https://www.gearslutz.com/board/high-end/)
-   -   Focal Twin6 Be Woofer / Crossover Issue.. HELP! (https://www.gearslutz.com/board/high-end/1313913-focal-twin6-woofer-crossover-issue-help.html)

Montreal 7th June 2020 01:19 PM

Focal Twin6 Be Woofer / Crossover Issue.. HELP!
 
Hi All,

Longtime reader, thanks to everyone for all the amazing advice. I've got a set of Focal Twin6 be and one of the woofers doesn't seem to work.

When i switch the L/R switch there is an audible difference one one monitor (apart from just which woofer is active in the higher freqs) and it doesn't want to play nicely up top.

There is either significantly less power coming from one woofer or no power at all. Its hard to tell as the other woofer still causes it to move but with my fingertips gently on the woofer I can feel less vibration.

Do you think this is an electronics issue or a woofer issue?

Getting in touch with Focal asap...

Anyone else had this issue?

Montreal 7th June 2020 05:02 PM

UPDATE:

I switched the woofers on the problematic speaker and was still having the same issue which was good as it must be the amp/crossover.

Then I sat, slightly happier but still somewhat unhappy.

I cranked up the volume a little bit and it was almost like something clicked (not sure if there was an audible click) and all of the sudden it was working normally!

Maybe it was a bit of dust or something but after A/Bing both speakers with the L/R switched again extensively the problem seems to have solved itself.

Previously the "filtering" caused by changed the L/R switch on my left monitor was audible even on a phone recording and now it seems almost exactly the same and you cannot even tell when I am flicking the L/R switch on the back panel.

Still going to ring Focal tomorrow to get more details!