Gearslutz (
-   PreSonus Studio One (
-   -   Losing MIDI controller assignment when changing VST (

Redbaron25 20th December 2019 12:38 AM

Losing MIDI controller assignment when changing VST
Hi all,

I've searched all the Forum posts here without finding anything relevant so hopefully someone can help with a small but annoying problem..

I tend to work in only 8 tracks (get more done that way) and have the Volume & Pan controls mapped to my Akai Midimix controller. Works great and the mapping saves and loads no problem. Each track is an instrument track containing a VST.

However, if I later change the VST contained in a track, the Volume & Pan MIDI mapping vanishes and has to be re-mapped. It's as though Studio One thinks I'm deleting the track and making a new one, which then needs re-mapping.

The controls in the 'Midi Learn' box still respond to my Midimix input but the assignment from there to the actual Volume & Pan sliders on-screen have mysteriously vanished. Seems to be a Studio One problem.

It just takes 10 seconds to re-map my controller but it's still annoying to have to do it every time I change a VST. I need the MIDI Volume & Pan assignments to stay with the track when I change VST...any ideas??


Quetz 3rd January 2020 11:31 PM

Did you find a solution to this?

Try creating your map template from scratch with empty instrument/midi tracks that have not had a vsti inserted on them yet.

Not sure if that'll work but worth a try.

Also, how are you mapping your controls to the S1 parameters?

Did you right-click on a track fader/pan bar and 'assign to', or did you do it via control link?

Redbaron25 7th January 2020 12:03 AM

Thanks for the reply.

I can create an 8-track template containing empty instrument tracks but the mixer controls don't show in the console, only the main master fader is there. So there's nothing on-screen to map the Midimix to.

However, if I then add a vst to a track then the mixer control appears and I can map it. It's like adding an instrument suddenly makes the track 'exist', even though it's there in the main window.

Once I've pre-assigned an instrument to each track I can then map the controller.

I map using the 'External Devices', right-click on the Midimix name, 'Edit' then 'MIDI Learn' in the box and the hardware controls all appear there no problem. I right-click on the appropriate channel fader and use the 'Assign to' function to map the hardware. No problems there. Saves and reloads the song just fine.

...but when I change ANY instrument for another..bang goes the link to the Midimix, though it's still linked up and working in the Global midi box. Only the fader in the console is disconnected each time. As a test, I mapped the 8 knobs on my M-Audio Axiom 32 to the faders too and they also vanish when changing instruments, so it seems to be the fault of S1.

I use Reaper too and that lets you create a blank track, map midi volume, pan, etc and they stay working even if you change the tracks contents - just wish S1 would do it too! Tried it with both v2.5 and 3.5 and same problem.


Quetz 7th January 2020 05:45 PM

Ok, gotchya.

The way you're doing it, you're mapping them globally, not in focus mode.
The two mapping modes in S1 are global and focus, but it's easier to think of global as 'static' and focus as 'dynamic'.
When you pick something using the 'Assign to' method, it's mapping them statically, ie they won't release to be mapped to new parameters in another plug.

This kind of link is confirmed by a blue arrow between controller name and parameter name.

You want to do it so there is a yellow arrow between the two, which confirms that as you move to different plugs the mappings will follow dynamically, updating to each new plug as you move through them.

To do this, only use the External devices panel to define the hardware knobs and faders. You need to unassign all the controls, start over, only use the External devices panel to create the physical control chart.

You can either unassign controls by right clicking again in the External devices panel and choosing unassign, or just move a hardware control, check the box at top left of the arrange window to see the current link, and then click the coloured arrow between the control name and parameters name so it goes dark grey.
Now it's unlinked.

From now on, you will link using the same method as you just used to unassign (box at top left), or by using the same feature found by clicking the little cog icon to top right of a plugin gui (next to the drop down box that shows the name of the hardware device currently assigned to its control).
Either of these methods can be used regardless of what functions you're mapping.

Now you'll see straight away by checking the arrow colour whether you've hard-wired a control (blue arrow) or whether it's available to be mapped to other things too (yellow arrow).
This will solve any issues you have with plug control and other parameters.
It's only solving half the problem though.

As you say, because the S1 console only shows channels (ie things that pass audio), not tracks, you won't see any controls there for a midi (instrument) track until you've inserted a vsti, then you'll see that vsti's audio channel/s in the console.
I have a suspicion that regardless of how you've mapped your controls, whenever you remove an instrument, the links for it will be broken, because the link was made with instrument-specific parameters (its audio outputs) and not a pre-existing mixer channel.

What you want to try and do is use those facts in your favour, by mapping the vsti controls (including output channel controls) dynamically.
I don't know if this is possible but I'll have a play in a minute.

Quetz 7th January 2020 06:12 PM

Just thought of something - you could use multi instrument tracks in your template instead of regular instrument tracks.

It acts as a wrapper for instruments, so its mixer channel is fixed, and changing instruments won't affect any mappings to its volume, pan etc.

Redbaron25 7th January 2020 06:17 PM

Thanks for the help. I was actually starting to think about ways to map the VST's themselves but it seems so unnecessarily complicated - the tracks (even when blank) clearly exist and you can create midi clips, enter midi notes, etc but it doesn't show up in the mixer window at all when blank grrr.

Though if I create a blank audio track the appropriate mixer fader appears no problem.

I've been 'replacing' the vst with another but I tried the 'keep' option so both old and new ones are there - same problem; I have to still re-map to the new one.

I don't actually do a lot of vst-switching anyway so can live with any re-mapping required but it would be nice to fix the problem anyway (if it's possible). I'll do a little more testing and experimentation along the lines you suggest.

I appreciate your efforts.


Quetz 7th January 2020 09:14 PM

Hi Steve,
Yeah you won't see any vsti channels in the mixer for a track with no instrument loaded, only audio outputs from loaded instruments appear as outlined above.

I just did a test myself using the multi-instrument track method I described and it works fine.
The multi instrument channel in the mixer and the vsti fader are independent that way.

Just create a template by dragging in a 'New Multi-Instrument' from the instrument browser onto 8 new instrument tracks.
Map your Akai to those, and they will stay mapped when you add, remove and combine instruments within it.

Redbaron25 8th January 2020 03:57 PM

Thanks! That's a workable solution to the problem - I've only just started using version 3.5 so hadn't even noticed the 'New Multi Instrument' option which is absent in version 2.5

Been having a play around with it and it offers some great possibilities of mapping and combining instruments - I'm trying to stay 'minimalist' so as to get stuff finished but I can see myself experimenting a lot with this :)

Really appreciate your help and advice, thanks again.