Gearslutz

Gearslutz (https://www.gearslutz.com/board/)
-   Music Computers (https://www.gearslutz.com/board/music-computers/)
-   -   MacOS 10.14 "Mojave": share your experiences here (https://www.gearslutz.com/board/music-computers/1231911-macos-10-14-quot-mojave-quot-share-your-experiences-here.html)

Diogo C 24th September 2018 08:23 PM

MacOS 10.14 "Mojave": share your experiences here
 
MacOS 10.14 "Mojave" is here, let's use this thread to help each other, report what's working and what's not working, post issues and workarounds and so forth.

Overview: macOS Mojave - Apple

Basic upgrade information: Upgrade to macOS Mojave - Official Apple Support

PS: let's leave company criticism and related talks out of this thread. Plenty of that going around already, so let's make this thread an useful resource for those using this version of the Mac OS.

kfhkh

Trendkill 24th September 2018 09:44 PM

Mac Pro 12-core, 48 GB Ram
macOS Mojave 10.14
No issues:
Universal Audio UAD
Izotope Ozone 8
Fabfilter
Waves V9
Kush Audio
Slate Trigger
Slate Digital
Eiosis
Lexicon
TC-Electronics VSS3
Superior 3
All Spectrasonics...

ten cent cat 24th September 2018 10:16 PM

Quote:

Originally Posted by Trendkill (Post 13535079)
Mac Pro 12-core, 48 GB Ram
macOS Mojave 10.14
No issues:
Universal Audio UAD
Izotope Ozone 8
Fabfilter
Waves V9
Kush Audio
Slate Trigger
Slate Digital
Eiosis
Lexicon
TC-Electronics VSS3
Superior 3
All Spectrasonics...

What DAWs are you using?

Trendkill 24th September 2018 10:19 PM

Quote:

Originally Posted by ten cent cat (Post 13535115)
What DAWs are you using?

Ah, sorry, my bad.
Logic Pro X 10.4.1

Samsung SSD with APFS

maxwelldub 24th September 2018 11:42 PM

just upgraded my 2018 13" MacBook Pro. Been having crackling audio issues from the purchase date, did all updates with high Sierra and no improvements. I get crackling with any buffer size lower than 512 in Ableton Live 10.0.3. Just updated to Mojave and no improvement. Apple is replacing my laptop but Im pretty sure this is a software problem related to the T2 chip and not defective hardware. Apple software quality control has really went down the sh*tter

Jayrawk 25th September 2018 03:23 AM

Apogee duet 2 not working after Mojave update.

Beatworld 25th September 2018 03:32 AM

Quote:

Originally Posted by Jayrawk (Post 13535475)
Apogee duet 2 not working after Mojave update.

Bummer.
The Apogee web site says it should ??

macOS Mojave and iOS 12 Compatibility Info - Apogee Electronics

-groovatious- 25th September 2018 07:06 AM

Getting an error firing up Waves Central (latest V9) - saying that it only supports MacOS 10.10+ and that I'm using MacOS 0.0

jacou 25th September 2018 10:15 AM

Quote:

Originally Posted by Jayrawk (Post 13535475)
Apogee duet 2 not working after Mojave update.

macOS 10.13 High Sierra - System Extension Blocked alert during software installation - Apogee KnowledgeBase

Also took me a while to find out. After that everything worked normal for me.

jacou 25th September 2018 10:16 AM

Quote:

Originally Posted by -groovatious- (Post 13535664)
Getting an error firing up Waves Central (latest V9) - saying that it only supports MacOS 10.10+ and that I'm using MacOS 0.0

Same here. Waves seems to be behind the schedule.. Not too surprised.
Waiting for a solution..

TNM 25th September 2018 10:32 AM

Quote:

Originally Posted by maxwelldub (Post 13535243)
just upgraded my 2018 13" MacBook Pro. Been having crackling audio issues from the purchase date, did all updates with high Sierra and no improvements. I get crackling with any buffer size lower than 512 in Ableton Live 10.0.3. Just updated to Mojave and no improvement. Apple is replacing my laptop but Im pretty sure this is a software problem related to the T2 chip and not defective hardware. Apple software quality control has really went down the sh*tter

If it was T2 chip would happen on my imac pro. Sounds like faulty hardware to me.. Testing Live 10.03 right now for someone in another topic to help them out, on 10.13.6 on imac pro, and so far it's performing very well. Don't despair, plenty of people using the T2 equipped macbooks and getting great performance.

stratology 25th September 2018 01:09 PM

Quote:

Originally Posted by -groovatious- (Post 13535664)
Getting an error firing up Waves Central (latest V9) - saying that it only supports MacOS 10.10+ and that I'm using MacOS 0.0

The newest OS supported by Waves 9 is 10.13.3, don't expect Waves to support newer versions of High Sierra (10.13.4, 10.13.5) or Mojave with W9.


The newest OS supported by Waves 10 is 10.13.5, no word on Mojave yet.

dven 25th September 2018 01:56 PM

Quote:

Originally Posted by TNM (Post 13535857)
If it was T2 chip would happen on my imac pro. Sounds like faulty hardware to me.. Testing Live 10.03 right now for someone in another topic to help them out, on 10.13.6 on imac pro, and so far it's performing very well. Don't despair, plenty of people using the T2 equipped macbooks and getting great performance.

It might be 2018 MBP specific since I have the same issue with external interfaces - random dropouts/crackling, etc. Internal speakers and phones are fine. From a thread on macrumors, it doesn't appear to be interface specific since there are reports of issues with Focusrite, RME and NI interfaces.

Its *extremely* annoying - as you'd imagine - and makes the MBP useless for any real audio work. I'm out of the 15 day usual return and I have not had the KP issues, so I'd like to think it'll be a sooner rather than later software update, but the realist in me is wondering if I should try the return and wait till rev2....

Dorian

maxwelldub 25th September 2018 03:20 PM

Quote:

Originally Posted by TNM (Post 13535857)
If it was T2 chip would happen on my imac pro. Sounds like faulty hardware to me.. Testing Live 10.03 right now for someone in another topic to help them out, on 10.13.6 on imac pro, and so far it's performing very well. Don't despair, plenty of people using the T2 equipped macbooks and getting great performance.

the iMac pro has a huge amount of CPU headroom compared to a MacBook Pro, not surprising you haven't noticed any dropouts bruh

do some digging, the internet is littered with reports of crackling MacBook pros especially the 2018 models. to make matters worse there's no utility to diagnose such problems (like latencymon on pc). such a situation is totally unacceptable given the limited hardware configurations apple has to test and the high price they demand for their products

Diogo C 25th September 2018 03:47 PM

Have a glitch with the trackpad (MBP 2015): sometimes when logging in the clicks won't work, the cursor moves around but clicking won't work at all. Kind of scary. Happened 6 out of 10 times when logging in since yesterday. Fortunately it "wakes up" once I connect my bluetooth mouse and the trackpad works fine after that.

TNM 25th September 2018 04:06 PM

Quote:

Originally Posted by maxwelldub (Post 13536204)
the iMac pro has a huge amount of CPU headroom compared to a MacBook Pro, not surprising you haven't noticed any dropouts bruh

do some digging, the internet is littered with reports of crackling MacBook pros especially the 2018 models. to make matters worse there's no utility to diagnose such problems (like latencymon on pc). such a situation is totally unacceptable given the limited hardware configurations apple has to test and the high price they demand for their products

Not really, I have the base imac pro, it's really not much more powerful than the 6 core 2018 MBP. I mean yes it's still more powerful but not hugely so.

My apologies in any case.. there is nothing more frustrating than crackles and dropouts for Audio users:(

I can take the imac pro to about 85% real usage on each core though without any issues, so i just thought it was all relative, that if the T2 was the issue, it would happen there too.

Is it only with ableton?

dven 25th September 2018 04:39 PM

Quote:

Originally Posted by TNM (Post 13536299)
Is it only with ableton?

I'm not sure its a CPU issue since I get the dropouts with even at low CPU usage and the glitches appear in Logic and playing a Youtube vid. For my case it seems to be a buffer/stream mismatch that appears to drops frames to the USB interface at random.

Deleted User 25th September 2018 06:29 PM

Ehh, we shall wait 6 months

TNM 25th September 2018 06:35 PM

Quote:

Originally Posted by dven (Post 13536350)
I'm not sure its a CPU issue since I get the dropouts with even at low CPU usage and the glitches appear in Logic and playing a Youtube vid. For my case it seems to be a buffer/stream mismatch that appears to drops frames to the USB interface at random.

Ok, it's entirely possible that it IS a usb issue, and that's why I am not seeing it since I use only a thunderbolt interface. So instead of diverting this excellent and important topic any further, I might join discussions elsewhere that are specifically aimed at the MBP issue (interesting to myself also as i eventually of course want to upgrade my 2014 macbook pro). Cheers

TNM 25th September 2018 06:36 PM

Quote:

Originally Posted by shanabit (Post 13536565)
Ehh, we shall wait 6 months

I am going to install Mojave this time next year or the week before it's successor drops. That way, everything will work for sure.

BTW, this is definitely the very last MAC OS that supports 32 bit apps of any kind, so keep that in mind for those still running 32 bit apps or plugins in a bit bridge.

Good luck early adopters! I will watch this topic with great curiosity!

dven 25th September 2018 06:39 PM

Quote:

Originally Posted by TNM (Post 13536574)
Ok, it's entirely possible that it IS a usb issue, and that's why I am not seeing it since I use only a thunderbolt interface. So instead of diverting this excellent and important topic any further, I might join discussions elsewhere that are specifically aimed at the MBP issue (interesting to myself also as i eventually of course want to upgrade my 2014 macbook pro). Cheers

Agreed. Best not to hijack this thread anymore. If I have any new info, I'll start a new thread.

amirgelman 25th September 2018 07:12 PM

UAD Apollo Twin - works perfect.
 
Took my chances with Mojave.
All works perfectly fine with my UAD Apollo Twin including legacy plugins and other non-related plugins.
Specs: MacBook Pro 2016, Core i7, 16gb Ram, SSD.

maxwelldub 25th September 2018 08:28 PM

Quote:

Originally Posted by dven (Post 13536350)
I'm not sure its a CPU issue since I get the dropouts with even at low CPU usage and the glitches appear in Logic and playing a Youtube vid. For my case it seems to be a buffer/stream mismatch that appears to drops frames to the USB interface at random.

Same, happens with any app (logic, safari, etc)

jacou 25th September 2018 08:37 PM

Quote:

Originally Posted by jacou (Post 13535836)
Same here. Waves seems to be behind the schedule.. Not too surprised.
Waiting for a solution..

Got it to work!
Here is a simple workaround for everyone that wants to install Waves V9 plugins in 10.14 Mojave:

In the downloaded and extracted V9 offline installer folder navigate to "Installers/V9/instl/minimum-requirements.json", open that file in a text/html editor and change "MacOS":"10.10" into "MacOS":"0.0", hit save and it's possible again to install plugins in the Waves Central L app.

hooppie

stratology 25th September 2018 08:51 PM

Here is the compatibility statement from Presonus.

In first tests, drivers for the old Firestudio Project seem to work without issue. I had to give permission for the kext in System Preferences>Security during the driver install.

stratology 25th September 2018 09:11 PM

Compatibility lists:

Sweetwater

Production Expert

Deleted User 25th September 2018 10:58 PM

Could someone just tell me how this OS update would benefit me since I do nothing with the OS?

I open up my DAWS and get busy. That is it, seriously

1. Are there AMS improvements?

2. Audio improvements for CORE AUDIO?

3. Midi improvements?

maxwelldub 26th September 2018 02:23 AM

Tim cooks favorite [email protected] bookmarks show up in safari now so coreaudio clocking should be much tighter

stratology 26th September 2018 02:35 AM

MOTU released a statement, all their hardware and software seems to be compatible with Mojave.


Great, MOTU is always on the ball when it comes to macOS updates..

Trendkill 26th September 2018 02:41 AM

E-mail from Soundtoys:
Quote:


Dear Soundtoys Users,

Our development team is currently looking into a few known issues with the way the graphical user interfaces of Soundtoys plug-ins are being displayed on the new macOS Mojave operating system. We advise that our users hold off on updating to Mojave until a compatibility update has been released. Please stay tuned for updates.

If you run into any issues using our plug-ins, please be sure to visit support.soundtoys.com.

We appreciate your patience while we work on this update!

Sincerely,
Team Soundtoys