The No.1 Website for Pro Audio
New PreSonus Hub stuck on Beachball, macOS
Old 27th December 2019
Lives for gear
Jim Rosebrook's Avatar

New PreSonus Hub stuck on Beachball, macOS

I am wanting to use Fat Channel in VST and AU using the new PreSonus Hub. Ampire installed and Activated Ok... but Fat Channel got stuck on beachball & need to force quit.

Using macOS 10.15.2.

Tried deleting whatever pieces of PreSonus Hub I could find and re-installing, but same result.

Anyone using this successfully?
Old 27th December 2019
Gear Head
djt4400's Avatar

This worked for me... I couldn’t find the link so I had to attach the screenshot I took the other day.. There’s another thread in the forums that talk about having to delete the fat channel vol 1 and reinstalling it in there somewhere too... I hope this helps!
Attached Thumbnails
New PreSonus Hub stuck on Beachball, macOS-9a00e306-9099-46c6-a348-1717b3baf0cf.jpg  
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump