The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
mbox 3 not working
Old 23rd February 2012
  #1
Here for the gear
 

mbox 3 not working

Hi, hopefully there is someone out there that can help me out. I just found out that my mbox 3 (not the mini or the pro) is stuck in firmware update mode when I plug it into my macbook pro all my LED's turn on and don't go off like normal. Also, my mac doesn't recognize that my interface is plugged into a usb port. It doesn't even show up on my device manager. I've tried to update the firmware but since it can't read the hardware it won't continue the installation. I have updated the mbox 3 to 1.0.21 but when I open the control panel for the mbox 3 it shows me the update version which is 1.0.21, but next to firmware there is no number. I don't know what to do i've tried everything. There is nothing on google to help me which sucks. I need to know if it's broken do I throw out the interface. I have only had it for a year and my warranty just ended this month. Someone please help me.
Old 6th March 2012
  #2
Here for the gear
 

Same issue

Hey man, I have the same exact issue. I kept getting that DAE error -61..whatever so I downloaded the latest mbox 3 drivers and installed them. Ever since then, it doesn't work. ALL my lights are on, so I know it's being powered. Somewhere I read that this means it's stuck in "Firmware update" mode. I tried reinstalling the driver i download and got the same result.


PLEASE HELP US!!
Old 21st March 2012
  #3
Gear Addict
 

Exact same thing happened to me. After updating to 10.0.21 drivers and restarting my MacBook Pro.

This really sucks~

Have any of you found a solution to this ? Any way to initialize the Mbox3 ?
Old 4th April 2012
  #4
Here for the gear
 

Still no resolution

I still have no resolution to this issue. My mbox 3rd gen was working perfectly until I updated it through the system preferences UI. Anybody have any luck with this? Any word from Avid?
Old 4th April 2012
  #5
Lives for gear
 
Cgbravo's Avatar
 

You should post at the DUC forum if you haven't done so already..

Avid Audio Forums - Powered by vBulletin
Old 3rd August 2012
  #6
Here for the gear
 

Did you fix this yet?

I have the same thing in my new Mboxpro3 this week. It got stuck in firmware and has been crazy ever since. The only way I can get it to work is to turn it on and let it get stuck then restart the iMac.

Here is what I posted on DUC
Hello all and welcome to my nightmare,

About a month ago i got the MboxPro3 and it shipped with Pro Tools 10. I was having the best time learning all the crap and the system seemed to work great.
Here is what i had.

iMac i5 4gig RAM Sno Lep - 10.6.1
Mboxpro 3 with the Aug 2011 Drivers, via Firewire
Pro Tools 10

So i got a little bold and thought I might add the Eleven Rack with Expansion Pack to the system and run it through S/PDif. I installed the drivers that came with the 11R but they turned out to be the old Mbox original release drivers. This was problem one.

Now the Mbox won't work, i called support we uninstalled the old drivers and put in the brand new June 29 2012 drivers for the Mbox. the Firmware updated and the Mbox worked again, or so it seemed. The funny thing is that now when I leave the computer and turn off the Mbox I can no longer just turn it on again and launch PT10 because no sound comes out and the inputs don't work. Every time I want to turn on the Mbox I need to restart the iMac after I turn on the Mbox and then make sure the little blue light on the Mbox it flashing before I start PT10 or I get no sound. Before i just turned it on and went to town recording.

So I call support again and they remote my Computer and look around and can't get it to work right without either reinstalling the drivers, which needs to be done every time, or restarting. They also had me boot from DVD and repair the HardDisk which didn't help. So I am still restarting.

Maybe firmware is causing the problem or I have conflicting Driver info somewhere on the Disk. My last guess is that the Mbox is syncing with some other program, but I installed nothing new aside from the 11R drivers.Has anyone seen this or have a way to fix it?

A list of stuff I do know.
Mbox is in the Setup Hardware section of PT
Mbox is listed as the Playback Engine
My I/O settings are all good
I tried switching these around to see what happens and nothing unusual takes place.
I have the latest Drivers from Avid for the Mbox and 11R installed
The Mbox Firmware says its .3 just like the driver says it should be.
System Preferences are set to internal speaker for sound, and if I switch them to Mbox I lose computer sound unless I restart after the switch.

The bad part is that I still can't figure out how to hook up the Eleven Rack S/PDif. When I restart so the Mbox works and the two units are connected with S/PDif Ins to Outs and I launch Pro Tools I can only see Mbox in The Setup hardware part so I can't switch clocks. I also don't know how to get the 11R sound through the Bus and out the mains or into the channel for that matter. I tried all the inputs that were listed. Does anyone know what might be going on there besides all the above crap?

Sorry about the long post but man this is a pain. I just want to play guitar ya know.

Jeff

Update: I have tried to turn on the Mbox and then start the computer but that don't work either. Seems like restart is the only way short of adding drivers every time. The eleven rack works fine on its own too.

I hope one of you cats knows whats up.
Old 3rd August 2012
  #7
Here for the gear
 

Another thing

When the problem started I installed (like a fool) the Mbox Pro Driver Dated June 8 2010. I assume that the driver is for an older model of Mbox. The question I have is where can I get an Uninstaller of this driver? Also, do uninstallers from other Avid Drivers work on all Drivers or is each one a separate matter? I would really like to know a 100% answer so if you don't know for sure please don't suggest one way or ther other about the Avid uninstaller.

I talked with tech support and they seem to think it is my Firewire cable. Not sure if that will work. They want me to get a native Firewire 400 to 800 cable because the adaptors are a known issue. That may be true but I am not sure. It's worth a try.

Let me know if you have any idea where I can get an uninstaller for that old driver. I want to make sure that the driver is all the way gone before I continue.

Thanks

Jeff
Old 5th August 2012
  #8
Here for the gear
 

Well, I did the cable thing and it still don't work. However, hooking up the cable I found that I can unplug and plug back in the firewire cable and the Mbox will work again. If I shut it off and then back on I need to unplug and plug back in the firewire to make it work again. Is there a way to mess up your Mbox by hooking up S/PDif cables? Cuz that's when this all started.

Thanks again

Jeff
Old 15th January 2013
  #9
Here for the gear
 

Quote:
Originally Posted by Muttzippy View Post
Well, I did the cable thing and it still don't work. However, hooking up the cable I found that I can unplug and plug back in the firewire cable and the Mbox will work again. If I shut it off and then back on I need to unplug and plug back in the firewire to make it work again. Is there a way to mess up your Mbox by hooking up S/PDif cables? Cuz that's when this all started.

Thanks again

Jeff
I'm having the same problem. Stuck in firmware update mode. Did u ever find a fix for this?
Old 6th December 2013
  #10
Here for the gear
 

Hi everyone I'm having a serious problem I bought a Mbox 3 pro I was very happy but now I'm up set I download drivers for it and it won't connect to the mbox pro control panel someone please help I have a Mac Pro with lion on it can someone give me the place to get the right driver to make it work
Old 15th February 2014
  #11
Here for the gear
 

Same Here

The same thing happened to me too. In the first month I started having to reinstall the driver every one to two days. Pain in ass. I'd know when only the blue light was flashing. Now (about 4 months in) the Mbox 3 does not work at all even if I install the driver. And now all the lights go on and off in sequence. I've tried everything. Bull****...

Are we going to have to pay to get this fixed???
Old 16th February 2014
  #12
Here for the gear
 

Did you uninstall the drivers and do a reinstall?
Old 18th March 2014
  #13
Here for the gear
 
joe973's Avatar
 

what woks for me is when i i turn on my computer and my mbox try to stream and fail what i do is while the computer is on i unplug the thunder bolt plug and plug it back in and it always work.
i guess the hardware fail when computer tries to read it at first but it could be on my end don't know thats my solution for know
Old 13th April 2015
  #14
Here for the gear
 

Hi, I hope someone can help, I have a mbox 3 brand new, and I am also new to this. I am trying to test each stage as I don't get any sound. 1. I plug a working mic into the back of the box, select the rear button, plug headphones in the front. Should I hear any sounds through the head phones, I see the clip light go on in the front so something is happening, but I don't hear any sound. I am trying to use audition 5.5 with yosemite on a mac but no sound comes through. It might be a cable so I am trying to test it bit by bit
Old 29th September 2015
  #15
Here for the gear
 

MBOX 3 - Rotating Flashing Lights & Hardware not detected

Yes Folks it seems this issue with the MBox 3 is viral. I purchased mine recently off a friend and since attempting to connect my MBox 3 Im having rotating Flashing lights and the hardware is not being recognised by the MBox Software application.
I have tried installing drivers many versions, restarting each time and still no change, had tried a printer cable to replace my current cable and no change still flashing....Im attempting to discuss with Avid Customer Care and hopefully once I transfer all the items into my name they may help.....If anyone can give me any tips to solve this problem that would be very helpful. Thanks Andy
Old 8th March 2019
  #16
Here for the gear
 

**** avid never again will i advocate their poor products and even worse cust serv.
Old 28th July 2019
  #17
Gear Head
 
tofermusic's Avatar
Any solution?
Old 3 weeks ago
  #18
Here for the gear
 

Quote:
Originally Posted by tofermusic View Post
Any solution?
This is a horrible problem that has plagued me for YEARS!! I got so disgusted with the lack of productivity, AVID support or a straight forward solution that I ate the $750 I spent years ago. This unit came as a package with Pro Tools LE 8.0.4 that I updated to 8.0.4/5 & it DID NOT COME WITH AN ILOK. I bought Pro Tools 10/11 from Mathew Fuller at Sweetwater for the same price w/iLok, Eleven Rack, perpetual license(Lifetime) & lifetime technical support. I couldn't beat that after several years on multiple boards trying to figure out a remedy. I still have the Mbox 3(3rd gen) & PT's 8.0.04/5 that I have no idea what to do with. I have been informed numerous times that 8.0.4/5 is the worst revision by far that AVID has ever released (just my luck). I know multiple individuals that use 6.x.x & 7.x.x with the firewire interface that is much older than mine, has no iLok & working perfectly fine(?). All I can honestly say is it's not worth the time, effort or frustration trying to salvage it unfortunately. Give it to someone that has a cracked version of any DAW and let them run with it.
Old 3 weeks ago
  #19
Gear Nut
 

http://duc.avid.com/showthread.php?t...ghlight=mbox+3

Avid quit support for it, which means no new drivers, etc. Sorry.
Old 1 week ago
  #20
Gear Head
 
tofermusic's Avatar
Quote:
Originally Posted by cruisemates View Post
http://duc.avid.com/showthread.php?t...ghlight=mbox+3

Avid quit support for it, which means no new drivers, etc. Sorry.
It's true. I talked with the authorized distributor and the same.

AVID MBOX 3 IS DEAD!
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump