The No.1 Website for Pro Audio
Universal Audio Releases UAD Software v9.12 featuring Neve 1084 Preamp & EQ Plug-In
Old 1 week ago
  #121
Quote:
Originally Posted by sirthought View Post
Reading through the release notes, it details which GUIs were updated this time:
  • UAD API 560
  • UAD API 550A
  • UAD AKG BX20
  • UAD Manley Massive Passive
  • UAD Manley Massive Passive Mastering

I don't really see a huge improvement. They are clearer to the eye—some of them use to be downright blurry—but you still can't resize them and the fonts can be really small and hard to read.

The Ampeg GUI, and plugin, is created by Plugin Alliance. Most of the UAD ones are really not standing out for their sharpness on todays screens. Thankfully they sound good.
Of those, I only own the BX20... but any GUI improvements are most welcome.

I haven’t dug in to the issue, but on the surface it seems silly that these stalwart plugins can’t at least get a static graphic facelift. They don’t even need to be resizeable; just a reasonable size for the majority of monitor resolutions in use today.
Old 1 week ago
  #122
Lives for gear
 
sirthought's Avatar
Quote:
Originally Posted by robshrock View Post
Of those, I only own the BX20... but any GUI improvements are most welcome.

I haven’t dug in to the issue, but on the surface it seems silly that these stalwart plugins can’t at least get a static graphic facelift. They don’t even need to be resizeable; just a reasonable size for the majority of monitor resolutions in use today.
They updated the Manley Vari-Mu sometime in the past 12 months or so, and I still find it very hard to read due to the size and font choice on the controls. I'm sure the font choice is what Manley chose, so hard to fault that, but the size could be easier to read.

I see plugins from companies like Valhalla and Fab Filter and the legibility and flexibility is really a strong suit. I dig the vintage gear look from UAD but if they could just make the GUI's resized, or just larger, that would really be a win for everyone.
Old 2 days ago
  #123
Lives for gear
 
Eigenwert's Avatar
Today I updated from Version 9.12.0 to Version 9.12.1. Since the update, I get „too much DSP load“ plugin deactivations in a 14 DSP system at maybe 40% load on a DSP intensive master bus. It happens completely out of nothing while all the plugins are running normally at first and then during playback eventually one plugin gets deactivated. I hope that @ Universal Audio can fix this soon. Is there a way to go back to Version 9.12.0?
Old 2 days ago
  #124
Gear Addict
 
4fmb's Avatar
Quote:
Originally Posted by Eigenwert View Post
Today I updated from Version 9.12.0 to Version 9.12.1. Since the update, I get „too much DSP load“ plugin deactivations in a 14 DSP system at maybe 40% load on a DSP intensive master bus. It happens completely out of nothing while all the plugins are running normally at first and then during playback eventually one plugin gets deactivated. I hope that @ Universal Audio can fix this soon. Is there a way to go back to Version 9.12.0?
Wow, thanks for the warning! That does not sound like fun at all!

Did you trash the 9.12 installer? If not, just uninstall the 9.12.1, then install the 9.12. Or if you are on Time Machine or other "historical" backups...there you go.

Hope that might help. Good luck!
Old 1 day ago
  #125
Lives for gear
 
Eigenwert's Avatar
Question

Quote:
Originally Posted by Eigenwert View Post
Today I updated from Version 9.12.0 to Version 9.12.1. Since the update, I get „too much DSP load“ plugin deactivations in a 14 DSP system at maybe 40% load on a DSP intensive master bus. It happens completely out of nothing while all the plugins are running normally at first and then during playback eventually one plugin gets deactivated. I hope that @ Universal Audio can fix this soon. Is there a way to go back to Version 9.12.0?
I might have used one plugin less on the master bus before updating so I am not even sure the bug was not there before.
Old 1 day ago
  #126
Lives for gear
 
Eigenwert's Avatar
Quote:
Originally Posted by 4fmb View Post
Wow, thanks for the warning! That does not sound like fun at all!

Did you trash the 9.12 installer? If not, just uninstall the 9.12.1, then install the 9.12. Or if you are on Time Machine or other "historical" backups...there you go.

Hope that might help. Good luck!
No time machine update of the software and I think I trashed the installer.
Old 1 day ago
  #127
Gear Addict
 
4fmb's Avatar
Quote:
Originally Posted by Eigenwert View Post
No time machine update of the software and I think I trashed the installer.
https://help.uaudio.com/hc/en-us/art...tware-Archives

Go here. Scroll down and you should be able to re-download 9.12
Old 1 day ago
  #128
Lives for gear
 
Eigenwert's Avatar
@ Universal Audio since 9.12.1 I got the authorization issues as well. Never experienced them before.
Old 1 day ago
  #129
Gear Addict
 
daaronhoffman's Avatar
Same issues here... shows only 50% usage and yet it keeps saying it’s out of DSP and shuts things down.

Quote:
Originally Posted by Eigenwert View Post
Today I updated from Version 9.12.0 to Version 9.12.1. Since the update, I get „too much DSP load“ plugin deactivations in a 14 DSP system at maybe 40% load on a DSP intensive master bus. It happens completely out of nothing while all the plugins are running normally at first and then during playback eventually one plugin gets deactivated. I hope that @ Universal Audio can fix this soon. Is there a way to go back to Version 9.12.0?
Old 1 day ago
  #130
Lives for gear
 
Eigenwert's Avatar
Moving around plugins in the slots helped to get it playing stable... However during startup of a heavy project (in the making since long ago) often crashes Logic (but sometimes it works)
Old 1 day ago
  #131
GBP
Gear Nut
 

Quote:
Originally Posted by Eigenwert View Post
@ Universal Audio since 9.12.1 I got the authorization issues as well. Never experienced them before.
Yes I have been getting authorisation issues in the last 2 months which I have never had before. Then I re-authorise and in the plugin window they are all authorised but then when load up a project UAD is disabled as needs authorisation but is fine in the system plugin authorise window...

Then I re-authorise and the same thing happens over and over like Groundhog Day....

I think UAD have really dropped the ball here on their core products since developing Luna.
Their support is overloaded due to Luna according to their support response email.
I guess they are quite stressed given the circumstances....

However, I am concerned that the whole development of the UAD plugins which is what I bought and invested in, are to take a backseat, neglected or even become extinct....

UAD Antares autotune real-time pro/advanced crashes Cubase almost immediately yet the original autotune UAD works, md3w5 crashed Cubase the other day. Never seen problems before with UAD but has recently started to be buggy.

Many companies are not even releasing vst2 ( being phased out) but only Vst3 now and UAD do not have VST3 nor any side chain......

I am becoming quite concerned as to where this will end up, reminds me of Mackie and Trackion...

Full disclosure, I haven’t downloaded Luna, but I really can’t see myself getting into this closed system that on the surface looks like a money pit.
Old 1 day ago
  #132
Lives for gear
 

Quote:
Originally Posted by Billy Pilgrim View Post
As we've learned from MickeUppsala, these guys are all fools, who just haven't realized their foolishnet yet! The moment they finally wake up they will drop all their UAD stuff, have their assistant work for a week or so to get a few Acustica plugins up and running on their system and remix all their classic albums to finally get that exciting sound.
That didn’t take long.

No way am I going to bail on UAD, I have
a lot invested in it, PLUS the UA plugins sound
awesome and are in every project.

Not gonna start throwing money at Acustica,
if that is what you use and like, go for it.
Old 1 day ago
  #133
Lives for gear
 
djrustycans's Avatar
 

I’m actually loving UAD (this week!!). On the Pulsar MU thread, somebody mentioned the UAD Manley Vari-Mu and how they couldn’t get the Pulsar to match the UAD.

Feeling pretty sceptical but intrigued, I decided to demo the UAD Manley and replace it in a current mix which used the Pulsar version.

The UAD version is better for me - it is more euphonic and less woolly but it reigns in dynamics supremely and transparently. Think I’m going to get it.. It is superb in M/S mode combined with my hardware SSL clone.

Just been re-demoing the API 2500 too and although I love the Sknote A25, the UAD is different and has a great punch to it.

I regularly use the Distressor and the Fatso for me, does things I’ve not heard in other plugins anywhere....

Anyway, will enjoy demoing others now the trials have been reset - it’ll be difficult to resist dipping in with the buy 3 get 4 offer!!
Old 21 hours ago
  #134
Lives for gear
 
Eigenwert's Avatar
The biggest problem with the 9.12.1 is how unstable it is regarding crashes.
Old 20 hours ago
  #135
Gear Maniac
 

Quote:
Originally Posted by Dave Polich View Post
That didn’t take long.

No way am I going to bail on UAD, I have
a lot invested in it, PLUS the UA plugins sound
awesome and are in every project.

Not gonna start throwing money at Acustica,
if that is what you use and like, go for it.
You do realise this was sarcasm on my part...
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump