The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Cubase 6 & reason 6 DAW Software
Old 5th December 2011
Gear interested

Thread Starter
Cubase 6 & reason 6

Has anyone managed to get cubase 6 rewired to reason 6 on windows 7 ultimate? And if so HOW? I've done a reinstall of my audio pc, tried it 32 bit (on both) and I cannot get cubase to recognise just won't show up in the devices menu. Has anyone solved this?
Old 6th December 2011
Lives for gear

I'm running Cubase 6 and Reason 6 under 64-bit Win 7 Pro (not Ultimate) and the two 32-bit versions seem to Rewire just fine. The 64-bit versions won't at the moment because, even though Propellerheads have implemented 64-bit Rewire support in Reason now, Steinberg haven't yet implemented it in Cubase. So you should (in theory) be able to get the 32-bit versions rewired just as normal.

However, I do recall seeing some mention of problems either on the Props or Steinberg forums a while back. If I can find it or remember what it was, I'll come back here with it.
Old 6th December 2011
Gear interested

Thread Starter
Cheers. Wonder if it's because I'm running ultimate?
Old 6th December 2011
Lives for gear

Hi again. Not sure whether it's a problem with Ultimate, although I wouldn't have thought so.

I had a scout around the Steinberg and Propellerheads forums and there are quite a few posts on there about Rewire not working with Cubase, but most of them relate to 64-bit support (which is confirmed as not actually implemented in Cubase yet). However, there are one or two mentions of it not working even when running the 32-bit versions. Some people seem to have found a fix for it involving the location and version of the Rewire.dll file on their systems, but I haven't built up a consistent picture of what they're actually doing and what's working or not.

If you want to do a bit more digging, one of the relevant Steinberg/Cubase forum threads is here. There are several threads that come up if you search on the Props forum, but not all of them relate to Cubase and some of them just seem to be people bitching about it not working, rather than shedding any light on the problem!
Old 6th December 2011
Gear interested

Thread Starter
Thank you Adrian! Yes I found the posts about rewire.dll and did move the locations but it made no difference. It's astonishing to me that two of the best applications don't work together! If I find the answer I'll be sure to post it here....
Old 6th December 2011
Lives for gear

I figured that the stuff about moving rewire.dll might not necessarily be a solution. Usually if there is a problem that is due to something fairly straightforward like that, you'll see more than just a couple of posts confirming it and explaining the exact steps needed to make it work. There just didn't seem to be a clear enough picture from what I could see - just one or two people saying that they'd moved this or that to here or there with no really consistent pattern to it.

None of which helps you get to the bottom of the problem though. So, to rule things out, here's a quick description of my setup that I know works. (This is from memory 'cos I'm not at home at the moment, but it should be close since I only set this lot up a couple of weeks back.)

The PC is running Win 7 Pro 64-bit (it's a new i7 based machine - I just upgraded from an old, clunky Dell thing last month).

Both the 64-bit and 32-bit versions of Cubase 6 and Reason 6 are installed.

In the case of Cubase, both versions were installed from a boxed Cubase upgrade DVD (I already had Cubase 5.5 on my old machine, so bought the upgrade and used the upgrade DVD to install a full, clean copy of C6 on the new system). I can't remember off-hand, but I think the version on the DVD was 6.0.3 (I'll check later when I'm home). I haven't yet installed any further updates such as 6.0.5 (planning on doing that soon).

In the case of Reason, it was installed from a download from the Props web site. I already ran Reason 4 on my old machine and took advantage of their "pay what you want" upgrade offer back in October to buy and download R6. The package that is installed is 6.0.1 (build 1544 I think, but don't quote me on that).

In both cases, I installed the 64-bit versions first and then the 32-bit versions immediately afterwards (since I'd already heard about the 64-bit Rewire problem by then). The 32-bit version of Cubase was installed through the standard installer on the DVD, choosing the 32-bit option when it asked which one I wanted. The 32-bit version of Reason was installed using the instructions in the Reason readme file (which is, basically, to create a shortcut that runs the Reason installer with an additional "/32" option on its command line).

And that was it. Obviously, they don't rewire when I run the 64-bit versions 'cos Steinberg haven't got that part of the act together yet. But firing up the 32-bit version of Cubase followed by the 32-bit version of Reason rewires them together just as you would expect.

As I said earlier, I really don't think that the differences between Win7 Pro and Win7 Ultimate could be responsible for it not working (although I could be wrong, but I'm struggling to see what might be the root cause if that was the case). So the first things to investigate are the installations of Cubase and Reason themselves. If you haven't applied the 6.0.1 update to Reason (assuming you installed a 6.0 build), that might be worth a try. Similarly, if your version of Cubase is different to mine, it might be worth installing any updates (if you're running an earlier build than mine). Conversely, if you're already running a later build/update of Cubase than I am, then I'll be back here and let you know if anything breaks in the Rewire department once I've got around to updating mine to 6.0.5.
Old 7th December 2011
Lives for gear

Me again. Just can't keep myself away from this little puzzler...

Anyway, I wish I had a complete definitive solution to report, but unfortunately we're not there yet. It turns out the version of Cubase that I had installed was 6.0.2 (not 6.0.3) and, although Rewire worked with Reason 6, there was a slight bug that I hadn't previously noticed - they played very, very slightly out of sync. I had an old project that ran fine on my old Cubase 5.5/Reason 4 machine, but when I loaded it into C6/R6 and hit play, Reason would start fractionally ahead of Cubase and the two would be slightly adrift from that point onwards. The weird thing was, if you stopped playback partway through the song and then started again, they seemed to lock back together properly. Weird! I did a bit of searching around on the net and found similar reports in various places, so it does look as though the Rewire support in Cubase has definitely had a few issues of late.

Having said that, we're still no closer to explaining a situation where it doesn't work at all. I've now done the Cubase upgrade that I had pending and am running Cubase version 6.0.5 (Build 357, Built on Oct 7 2011) alongside Reason version 6.0.1 Build 1544 (as I thought). And the two are still rewiring together correctly (when run as 32-bit) and it even looks as though that strange sync error that I just mentioned has been fixed.

So... To give you a little more information to work with, I've just taken a look-see to find out what ReWire.dll files this machine has on its system drive. There only appears to be three of them:

One is in Program Files (x86)\Common Files\Propellerhead Software\ReWire. It's 1.36MB in size, has a file version of and a product version of 2.6.0. (This will be the 32-bit ReWire DLL.)

One is in Program Files\Common Files\Propellerhead Software\ReWire. This one is 2.08MB in size, with file and product versions the same as the above. (This will be the 64-bit ReWire DLL.)

The last one is in Windows\SysWOW64. This has a file size of 360KB, a file version of and a product version of 2.5.

All of these files are Copyright Propellerhead Software AB.

I'm not sure, but I'm wondering whether it is something related to the third of these that might be causing your problem. The Windows/SysWOW64 folder is intimately involved in the loading of DLLs when running 32-bit programs on Windows 64-bit machines. Since a 32-bit program needs to load 32-bit versions of all its DLLs, but those DLLs will usually have the same names as their 64-bit counterparts, Windows has to have a mechanism to make sure that the right version of each DLL gets loaded when it's wanted. It does this using some kind of folder redirection scheme involving that Windows/SysWOW64 folder. Now, this is only a guess on my part, but if your machine doesn't have the right thing in that SysWOW64 folder, I wonder whether this would prevent the appropriate 32-bit version of the ReWire DLL being loaded by Cubase and/or Reason when you start them up. If so, that would prevent ReWire working when running the 32-bit versions. We already know that 64-bit ReWire isn't supported in Cubase yet, so that's no ReWire all round.

The other possibility is that your system has the right file in Windows\SysWOW64, but that User Account Control settings (those annoying little popups you get when you try to install things) are preventing it working correctly. There's some kind of mechanism built into the SysWOW64 redirection that forces the system to load the 64-bit version of DLLs if an attempt to load the 32-bit DLL would cause a UAC prompt to appear. Again, if this happened, it would prevent ReWire working as Cubase wouldn't know what to do. One possible way to test this would be to turn UAC off (go to Control Panel, User Account and Family Safety, User Accounts and select the Change User Account Control Settings option. Set it to Never Notify). Once you've done that, try the 32-bit versions of C6 and R6 and see if they magically start working - it's a long shot, but it might work.

Phew. Looks like I've just written the music computer version of War and Peace there. Oh well, I just hope that some of it helps and that you can get to the bottom of this problem. If some of it does pan out (e.g. you discover that one of those files appears to be missing or that the UAC thing works), let me know as I might report that back over on the Steinberg forums where people have been having trouble.

Good luck!
Old 7th December 2011
Lives for gear
Kindred's Avatar

hey mate...+1 here

I can't get these two to Rewire either...

Have been bouncing down audio from Reason and then loading up in Cubase as a temporary solution ( i am only using Reason to start track ideas on my laptop)
Old 7th December 2011
Gear Nut
Beano Bean's Avatar

I am in the same boat guys. Here is what i have posted on the props/steinberg site :-

I am having a problem getting Rewire to work.

I recently reformatted my PC and i have put both Windows 7 32 and Windows 7 64 on separate drives. I am using Windows 7 32 bit for my music software (due to my Waves Plug ins not working in 64 bit at all), and my film editing software on the 64 bit OS.

I have installed Nuendo 5.5.1 32 bit on my 32 bit OS as well as Reason 6.01. When i open Nuendo and go to the devices panel, there is no instance of the Reason Rewire device.

I saw a thread on a forum saying to copy the Rewire.dll into the Nuendo folder and delete it from the Reason folder. I tried this and the Reason Rewire device showed up in Nuendo but it could not open.

I have been on to the Propellerheads tech support and they suggested deleting the Rewire, Rex shared library and the Reason Engine and then opening Reason. This did not work either as the program wouldn't open due to the REX shared library not being there.

I then reinstalled Reason, both version 6 from the DVD and 6.01 from my hard drive and again the Reason Rewire device doesn't show up in Nuendo.

I had a similar problem on my macbook pro, so i changed the reason settings to run in 32 bit mode and it worked, so just to make sure i followed the instructions in the read me to install 32 bit reason on a 64 bit machine (by using the shortcut " /32 method) just to make absolutely sure it was installing the correct version and i still had no luck

If any one else has had the same issues and can offer me some advice that would be great :-)
Old 7th December 2011
Lives for gear

Kindred - what's your setup? Not that I can shed much more light that what I've already posted here. Sometimes feels like I might have the only C6/R6 system in the world that is working so smoothly! (Bear in mind that, in some ways, my current setup is an ideal case, since it was all installed fresh on a new machine with very little else on there.)

Beano Bean - don't really know about Nuendo, although I would have thought that some of the stuff I posted earlier might be generally applicable. I've got Cubase 6 rewiring perfectly normally with Reason 6 on a Win 7 64-bit machine (but running them both 32-bit as Steinberg don't support 64-bit Rewire in Cubase yet - don't know about Nuendo). Anyway, unless there's something hidden somewhere that I didn't see, the only ReWire DLLs on my system are the three that I described earlier - none of them in any of the Steinberg directories/folders.

Not sure what more I can add, but if anything occurs to me I'll come back here with it.
Old 7th December 2011
Gear interested

Thread Starter
Thank you to all who've replied, especially Adrian who has come up with some interesting pointers which I will try when I get back to the studio tonight. I'll post the results back here later on!
Old 8th December 2011
Gear interested

Thread Starter
IT WORKS !!!!!!!!

Adrian is quite right. It appears the problem is with the SYSWOW folder.

Here's what I did to fix it:

1. I did a search on REWIRE.DLL

2. I opened the WINDOWS\SYSWOW64 folder and noticed there was no REWIRE.DLL file in there

3. I copied the REWIRE.DLL file into SYSWOW64

4. I then opened Cubase 32 bit: Reason rewire was for the first time listed in the DEVICES menu.

5. I opened Reason in 32 bit mode and hey presto it was in Rewire mode.

I'd like to thank all those who posted, and a massive big thank you to Adrian who if he ever ends up in the Colne Valley deserves a drink or ten!

I am one happy bunny!
Cheers all
Old 8th December 2011
Lives for gear

That's a great bit of news - I'm so glad to hear that it's working for you.

I'm not sure exactly how the folder redirection mechanism on that SysWOW64 folder is supposed to work (I might spend a couple of hours digging into Microsoft's Win 7 developer documentation sometime to find out more), but if dropping the appropriate DLL in there fixes the problem, that's good enough for me.

Have fun!
Old 11th December 2011
Gear Nut
Beano Bean's Avatar

Hi Guys. I take it the SYSWOW64 folder is for 64 bit windows. Is there such a folder on Win 32?
Old 14th December 2011
Lives for gear

Sorry I didn't reply to this sooner - I didn't spot the question.

Anyway, yes the SysWOW64 folder is for DLLs, etc. that are needed for 32-bit programs running under 64-bit Windows, so you would only expect to find it on a 64-bit Windows machine.

On a purely 32-bit machine, you should just need to ensure that an appropriate version of the 32-bit ReWire.dll file is somewhere in the standard search path for all DLLs. There are various places that you could put it, since there are various standard places that Windows will search for any DLL that it tries to load. For example, it searches:

The folder that the application you're running is stored in (this will usually mean the folder containing the .exe file that runs the application);
The system folder (default is usually C:\Windows\system32);
The Windows folder (default is usually C:\Windows);
The current folder when you started the application (usually whatever is specified in the shortcut that runs the application);

plus other places. Individual programs can also specify even more folders or specific locations that they will use when trying to load a DLL.

From the point of view of rewiring Cubase to Reason on a standard 32-bit Windows setup, the easiest and quickest way is probably to ensure that there's a copy of ReWire.dll in C:\Windows\system32. That should allow absolutely any program that tries to run ReWire to find the DLL. If you're on a 32-bit machine, you should only have a 32-bit copy of the DLL (possibly dropped in somewhere like Program Files\Common Files\Propellerhead Software\Rewire by the Reason installer), so there are no worries about possible conflicts between 32-bit and 64-bit versions of the file. Just taking a copy of the ReWire.dll file and dropping it into C:\Windows\system32 should ensure that Cubase can see it and load it when it needs to. (If that doesn't work, something much weirder is going on or your Cubase/Reason installs may be broken somehow.)

[Edit: Hi BeanoBean - just realised that you posted earlier about Nuendo. Anyway, whatever I've said above should also apply in the case of Nuendo. So long as the appropriate DLL can be found in one of those places that the system will look for it - and C:\Windows\system32 or its equivalent is usually a safe bet - it should work. I don't really know Nuendo at all though, so I'm not sure what you'd expect to see when you start it up. Hope it works out anyway.]
Old 26th December 2011
Here for the gear

Adrian you are a champion, I couldn't get Cubase 5, Cubase 6, Nuendo 4, or Pro Tools 9 to rewire with Reason 6 in Win7 Pro 64bit, but replacing the existing rewire.dll in the SysWow64 folder with the one from 32bit Common Files has solved it. Thankyou very much for that.

It seems that the Rewire.dll that was already in the SysWow64 folder was an older file and was only a few hundred kb's in size compared to the 1.6mb of the new file. Maybe it was originally from Reason 5 (which had previously been installed), and because Reason 6 automatically tries to install the 64bit version on Win764, installing the 32bit version doesn't replace the file.
Old 17th September 2012
Gear interested


Thanks guys!

Everything was working great for months, however Cubase 5 would crash once in a while and it was becoming more often.

Then yesterday, continually reason 5 crashes when rewire connection attempted with Cubase 5 on Windows 7 Ultimate.

I was trying all of the ideas I found on the internet all day yesterday and nothing worked.

I did a rewire update and it was older. Then I was getting this message.

"rewire installation failed because access to a file or directory was denied while installing the rex dll in the system directory"

Then I finally found your detailed discovery here and I'm happy to report that simply copying




solved my problem! Thanks! I hope this can help others too.

Next I was going to try the 32-bit install, however I hope that isn't needed now!

Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread Starter / Forum
SRDmusic54 / Electronic Music Instruments and Electronic Music Production
Drummer69 / Electronic Music Instruments and Electronic Music Production
Zabamusic / Steinberg Cubase + Nuendo

Forum Jump
Forum Jump