The No.1 Website for Pro Audio
Apogee Duet 2 drivers are bad bad bad!
Old 2nd March 2014 | Show parent
  #331
Lives for gear
 
🎧 5 years
Quote:
Originally Posted by suncake View Post
Just adding my +1. I've been having a miserable experience with my Duet 1 (FW) + 2008 Mac Pro + Live 8/9 + the last 2 years (currently 10.9.2). I keep getting pops/crackles while in Ableton. I have to increase the buffer size to 512 to make it bearable, but even that occasionally distorts. The muting/input selection controls from the dial are also spotty.

I'm unclear whether this is Apogee's fault, with their lack of Maestro updates for the Duet 1, or if this is Apple's fault. I thought the Duet was class-compliant, so shouldn't the issue lie with the Core Audio FW implementation?
I get the same in logic with the same buffer with my 2012 Macbook Pro. Also, sometimes the headphone out will stop working
Old 2nd March 2014
  #332
Lives for gear
 
JblKid95's Avatar
 
🎧 10 years
So is the Apogee Symphony. It's a nightmare... BAD BAD BAD DRIVERS!
Old 4th March 2014
  #333
Gear Head
Hi!

Im a hackintosh builder, and one of my clients was very happy with his new machine, started working with pro tools 10.3.8 with duet 2, and on the second day of recording, the inputs stopped, metering a clipping signal, but it presents,no audio on pro tools. Nothing can take away this clipping from it. And worse! When he plugs it to his macbook pro it works flawless... Im sure its not the machine, because before i sent it to him, i have worked with different interfaces without problem (firewire 410, digi 002, mbox 2...)

Now how can I convince him that its not a computer problem.... Very sad...
Old 4th March 2014 | Show parent
  #334
Gear Maniac
 
slugworth's Avatar
 
🎧 5 years
Quote:
Originally Posted by KennaOkoye View Post
So is the Apogee Symphony. It's a nightmare... BAD BAD BAD DRIVERS!
apogee does NOT write drivers...only installers. most of the interface manufacturers that write actual drivers are not having these issues.

total lame sauce...
Old 4th March 2014
  #335
Gear Maniac
 
🎧 10 years
I owned the original firewire Duet for a couple of years and it worked flawlessly, it really did 'just work'.

I can not say the same thing for Duet2 (mac only version), it worked ok with a 2010 iMac but when I bought a late 2012 iMac with USB3 ports it became very unreliable, I would have to plug and unplug to get it to be recognised by the iMac. I opened a few support tickets with Apogee tech support, they were polite but quite evasive about acknowledging the problem.

Like anything you can only vote with your feet, so I sold the Duet2 and upgraded to the Apollo Twin, the thunderbolt connectivity has been rock solid reminds me a lot of the original Duet on Firewire, it 'just works'.
Old 4th March 2014
  #336
Lives for gear
 
JblKid95's Avatar
 
🎧 10 years
just reloaded the firmware... Its annoying because I have to burrow a friends computer because I have usb 3.0. It is still finicky. Clicks on and off with thunderbolt.
Old 5th March 2014
  #337
Gear Head
Ok guys SOLVED the problem... And it wasnt Duet that was causing it... It was an instance of Cameleon 5000 that was glitching pro tools, and my client got scared....

So, i dont have any bad experience with it, but with all your input, its certainly clear that this company should improve its support.

Oh just remembered, the first time i booted with Duet plugged up, the Computer didnt recognize it, had to unplug an replug...

CUSTOMIPC.BLOGSPOT.COM
Old 7th March 2014
  #338
Gear Nut
 
🎧 5 years
Is there somewhere you can download previous driver versions of apogee products? I can't see anywhere on their website..

I have an issue and want to see if reverting back to a driver prior to the duet for ipad/mac 'January 2014' software installer might help.
Old 3rd April 2014
  #339
Lives for gear
 
JblKid95's Avatar
 
🎧 10 years
either way they're horrible. I use to have a an MR816csx, no interface has worked as well as those did on my mac. I never noticed it was even there. Symphony is a nightmare since day 1. Once it's on it's on. After sleep, or once I turn the computer on, problems begin. Restarting, logging out and back in, helps, but every time??? thats just ridiculous.
Old 28th October 2014 | Show parent
  #340
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by bwb011 View Post
I've used my duet 2 with three macs, a 2007 Mac book, 2011 iMac, and late 2013 Macbook pro. For the first year or so I would have to hot patch the Duet a few times for it to be recognized by the computer (usually five minutes or so, on rare occasions up to 45 min). I spoke with customer support and my experience was bad enough that I stopped trying to fix it and figured I liked the sound so I'd live with the inconvenience on startup.
+1 here for a very similar experience. After almost two years of bliss with my Duet 2 on a MacBook Pro (2006), a MacBook Pro (late 2011) and an iMac (mid 2011), the connectivity problems came super fast and super hard. Tried upgrading the iMac to Mavericks at the time to see if maybe performance was improved on one machine over the other but was still just all around terrible, sometimes disconnecting every 15-20 seconds, also for up to 45 minutes.

To add insult to injury, on my second repair ticket about the issue the customer service rep closed the file with advice to try different cables and computers, even though I had done both since day one. Will definitely not be supporting Apogee again and wouldn't recommend them.
Old 28th October 2014 | Show parent
  #341
Lives for gear
 
🎧 15 years
Quote:
Originally Posted by KennaOkoye View Post
either way they're horrible. I use to have a an MR816csx, no interface has worked as well as those did on my mac. I never noticed it was even there. Symphony is a nightmare since day 1. Once it's on it's on. After sleep, or once I turn the computer on, problems begin. Restarting, logging out and back in, helps, but every time??? thats just ridiculous.
Same for me.

Also, out of nowhere my Duet 2 just stops working for the most basic of things.

Forget about screwing up in my DAW, You Tube videos will just stop making sound regularly, iTunes... basically everything/anything that's supposed to make sound.

NEVER had any of these problems with Duet 1. This thing has been a pain since day one.

Tried tech support and that went nowhere for me.

VERY frustrating piece of gear.
Old 24th January 2015
  #342
Here for the gear
 
🎧 5 years
Hi there, I also had problems with loading Duet 2 on my Mac (OSX 10.9.5). This was connected from the Mac straight with usb-cable on the duet 2.

Now I have switched it on the adapter that comes with it and it works.
So line-up: Duet 2 (with power adapter) --> usb-cable (don't know if it's the original (I have to many)) --> USB hub (not powered with adapter) --> Usb cable (from usb-hub to Mac) --> Mac
And it works fine now!

Hope it helps..
Old 8th April 2015 | Show parent
  #343
Lives for gear
 
🎧 15 years
Random Disconnecting and Wake From Sleep...

Wondering if it's still common with people that their Duet II disconnects randomly and is pain to get going/connected when waking from sleep?
Old 12th May 2015
  #344
Gear Maniac
 
Brento's Avatar
 
🎧 5 years
Hi Football. No, for me the Duet II has been just fine for quite a while... Apogee released a firmware update a long time ago that took care of the newer iMac USB problem.
I have been happy ever since.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 1799 views: 435359
Avatar for schmudd
schmudd 18th December 2016
replies: 358 views: 142584
Avatar for Tim Farrant
Tim Farrant 3rd October 2012
replies: 75 views: 28173
Avatar for Leevi
Leevi 31st October 2015
replies: 121 views: 27488
Avatar for Sigfried Chicken
Sigfried Chicken 6th November 2017
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump