The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Problems with Stillwell in Logic Effects Pedals, Units & Accessories
Old 16th September 2011
  #1
Here for the gear
 

Problems with Stillwell in Logic

I have a Mac 2.4 Ghz 8 core w 14 gigs ram running OSX 10.6.8 and Logic 9.1.5

I can't for the life of me get any Stillwell or Schwa plugins to work in Logic. I remember having them work a month ago before I got a new SSD HD and started over all over again. So far I've tried putting the components in both my user and the system component folders, asking Logic to rescan audio units and restarting god knows how many times. When opening Logic I can see it recognize some Schwa and Stillwell plugs but they don't come up on the insert list OR the AU manager. What's even nuttier, is that they open just fine within Maschine even when Maschine is being hosted within Logic! This could be a workaround if Maschine weren't so heavy on the processor. Anyway so the files are fine but Logic doesn't want to see them for some reason. Anyone have any suggestions?

Thanks, I'd appreciate any and all input no matter how seemingly mundane they may be. HELP!
Old 16th September 2011
  #2
Gear Head
 
engelen62's Avatar
Did you check the Audiounit manager?
Old 16th September 2011
  #3
Lives for gear
 
lysander's Avatar
 

If you're running logic in 64bit you need to restart at least once in 32bit for 32 bit plugins to be scanned.
Old 16th September 2011
  #4
Here for the gear
 

Yes I tried starting in 32 and 64 bit. I also tried removing all AUs from the plugins' AU folder and restarting logic adding one plug every time but Logic just doesn't GET Stillwell. I can see the stillwell name flash across the splash screen when I start Logic but the plugs don't appear in the AU manager OR the insert menu. What's double weird is that they work just fine on my dual core intel macbook. odd, eh? seems like it happened when I installed Izotope's Stutter Edit. But they won't work even when I remove that file. I remember when I installed Stutter Edit, the first time I started Logic, there was a warning about incompatible plugins but I didn't know what it was. Is there a chance Logic blackballed Stillwell? Is there a way to undo that action?
Old 16th September 2011
  #5
Here for the gear
 

Sorry, I mean Izotope's S T U T T E R Edit plugin.
Old 16th September 2011
  #6
Gear Maniac
 

I've posted several times about issues I've had with Stillwell Rocket compressor under Logic but to no avail. The problem I have is that the plugin ALWAYS crashes the 32bit audio bridge when I attempt to change any settings on the comp or load a new preset.

I've emailed 2-3 times to Stillwell but I never get a reply even when I have expressed my genuine desire to purchase the plugin subject to the problem being resolved as I think it's a wonderful sounding compressor.

Not sure what's going on for you either but it seems Stillwell are really not that interested in customer support which is a great shame. I was wanting to demo their other offerings but I think it's time to look elsewhere. I would have thought a couple of emails or replies in these forums would be forthcoming. It seems some users have no issues under Logic but obviously others do.

I've tried rescanning the AU manager bus several times (both in 32 bit mode & 64) but it doesn't help.

I've asked Stillwell if the issue is only in the demo but again, no response.

Frustrating.
Old 16th September 2011
  #7
Here for the gear
 

FIXT

AT LAST!!! I fixed it. After deleting Logic, removing all AUs and reinstalling Logic, I was able to see Stillwell's stuff in the Logis's AU manager. From there, I had to click each one twice for Logic to fully recognise it's existance. I did this one by one restarting Logic each time to isolate any ugly plugs. Turns out Stillwell's Oligarc Filter was buggy so I left it be. What I'm concluding is that since I dropped all the components in the AU folder at once after starting over with a new SSD, Oligarc Filter caused the incompatibility screen to appear showing 20 something plugins that weren't quite perfect. I must have clicked the 'quarentine' or 'forget forever' button because I was never able to see them again untill full a reinstalation of Logic. Problem solved.

Solution: 1) remove all plugins to new folder 2) delete and reinstall logic 3) reintroduce individual plugins opening logic in 32 bit mode and clicking twice on the respective plugin's box within Logic's AU manager to fully validate each plugin.

Looks like my one bad apple spoiled em all.

It's validated... Now lets hope it doesn't crash my bridge too. I'll hollar if it dose. Thanks for all the good input everyone!
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump