The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Any issues with GB GA-X58-USB3 LGA 1366 X58
Old 20th December 2010
  #1
Lives for gear
 

Any issues with GB GA-X58-USB3 LGA 1366 X58

Hello, Should I expect any issue with a daw based on this gigabyte MB? planning on using it with an i7 950, and 3 x 4 1600 memory. thanks in advance.
Old 20th December 2010
  #2
Gear Maniac
 

You might. Especially if you are building the computer and purchase a board from Newegg/Amazon etc. It's called DOA. And I'm not kidding. Check out the Customer reviews. Other than that, this thread might give you as much clue as possible.

i7 Builds - Specs and Results - Avid Audio Forums

btw, I don't profess to have experience with this board. But I researched it for quite a while before buying. Mine is an EVGA 3xSLI Classified. Works great for my hardware/needs at the moment.

However, there's been a lot of recommendations for the gigabyte board, especially for PT users, which is why it has become the defacto board at the Avid site(which seems odd..I always thought PT was a Mac app. But I use Reaper so what do I know.)

I'm actually going to try it in my second computer. The evga board is for graphics/folding.


Anyway, my non expert .02 for what it's worth.
Old 20th December 2010
  #3
Gear Nut
 

I got the parts arriving today same as you spec'd...I'll report back after the build. Probably a couple days. Gskill 1600 ram/ corsair 650watt/Seagate drive/WinXP(go to Win7 after I get XP up and running)
Eric
Old 22nd December 2010
  #4
Lives for gear
 

thanks for the replies

Thanks guys for the replies and link. And good luck Eric and I hope you post the results of your build.
Old 24th December 2010
  #5
Gear Nut
 

Ok...update for you. It went really well, better than I expected. No firewire issues and only a few win 7 upgrade compatibilities which I expected.

The only build hiccup was forgeting to plug in the 12v CPU power supply because the manuel didn't mention it.

I had to upgrade to latest ver of Sony Acid, my Mackie Onyx FW interface works really well after driver update. I haven't tried the presonus Firestation yet but will probably put that one out to pasture and find another lightpipe interface to replace it since it is discontinued and the driver support is over. I haven't tweaked and stress tested everything yet but I am totally impressed so far.

My main recording platform is Samplitude 7 and it seems to be running well at 96k. I expected to have to upgrade but so far so good.

Thats all for now...I say go for it.

Eric
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
Flo Fandango / Music Computers
57
BlueBerry / Music Computers
2
NEVO / Post Production forum
1
JimiB / Music Computers
18

Forum Jump
Forum Jump