The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
New Drumagog Question
Old 24th June 2005
  #1
Lives for gear
 
MJGreene Audio's Avatar
 

New Drumagog Question

So I have gone thru the archives about Drumagog but haven't really found the answer to this question.

I downloaded the demo of Drumagog today and started playing with it. I am running PT HD-3 on a G-5 and with Drumagog on and ADC on I am still getting a tiny bit of flamming. Is there anyway to get this 100% sample acurate with the original sound or does it always have just a bit of latency. I tried the setting at 1ms and also 30ms and shifted the triggering track back by that amount but there is still something there. Am I nuts? (Don't answer that about me as a person) or am I just missing something? I love it and was looking for another alternative to Sound Replacer and I am still waiting for TL Drum Rehab. I love what it does but the latency is bugging me.

Thanks in advance,
Michael Greene
Old 24th June 2005
  #2
Here for the gear
 

I work with Sonar 4, not PT.. But what seems to work best for me is to bounce the drumagog track to a new track and then line it up with the original..not to mention it takes a load off the cpu..

Kevin
Old 24th June 2005
  #3
Gear Nut
 

This is a little over my head -

I think what you are hearing is the lag in the AU processing pipes -


The unix sockets that the the Core Audio Units create have thier own latency that is outside of the regular audio processing stream. These latency times are usually really small, usally a few ticks behind RAM speed so in the nano second range.

Then Drumagog must interpet, (RAM+CPU+RAM)
Check it's conversion table (RAM+CPU)
Load the requested sample (RAM (possible disk access))
Substitute Sound (CPU --> RAM --> Match level etc)
and
send sound back out - using another pipe in AU socket.

if your G5 is doing other things - playing back other tracks, ect ... then you could be putting uncessary overhead into the mix

if the sample you are trying to convert is a very high resolution sample you are adding more fuel to the fire by introducing some overhead on the disk access.

There are too many variables and now I am starting to confuse myself -----


Try less load and if you are using high resolution try lower resolutions (you converting it anyway right) if it gives you less lag then okay if not then you haven't lost much except some time.


CIAO
Old 24th June 2005
  #4
Lives for gear
 
MJGreene Audio's Avatar
 

Thanks guys. I appreciate the help. I will play with it some more and see what I come up with.

Thanks,
Michael Greene
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump