The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Anyone Having Logic 8 Control Surface Problems? Control Surfaces
Old 13th September 2007
  #1
Lives for gear
 

Anyone Having Logic 8 Control Surface Problems?

I'm having quite a time getting my control surface (a Tascam US 2400) to mesh with Logic 8--anyone else conquered this one yet? When I do the control surface setup sometimes it sees it and sometimes not.

When I go to the scan or add window, sometimes it shows me a list of controllers but most often nothing--no control surface templates, nothing. When I hit the add or scan buttons nothing happens either.

I've tried opening it with the controller in Mackie emulation, Logic mode and native mode, nothing seems to make much difference. Midi is getting through and the controller still works fine in Logic 7.

A few times it has shown me the full list of supported controllers but that didn't last long and it's crashed numerous times trying to fix it.

I noticed on another board someone else was having similar problems--anyone here have any similar problems or any answers?

Eben
Old 14th September 2007
  #2
Lives for gear
 

Answering myself--a first. (At least in the forum world).

There seems to be a conflict with Apogee's drivers that does not allow Logic 8 to recognize certain control surfaces (maybe any?). I have an Ensemble and my Tascam US-2400 was completely invisible to Logic when I booted up with the Ensemble on. Could not even install in manually (or find any other controller descriptions. --For the record, the US-2400 is one of the supported control surfaces for L8, with it's own plug-in in the midi plug-ins folder.

There was another post on another forum where someone had the same problem with a Symphony card.

Once I turned off the Ensemble and restarted Logic 8, the US-2400 was there immediately with everything functional. I was even able to then turn on the Ensemble.
Old 14th September 2007
  #3
Gear Addict
 
ptbarnum's Avatar
 

I am the symphony holder having problems with controllers that the ALLMYTEE spoke of.

hehe.
i redownloaded the tranzport driver, which seemed to jog Logic into recognizing controllers, but a quit and restart of the program left me out of control again
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
rattledaddy / Music Computers
2
sasha222 / Gearslutz Secondhand Gear Classifieds
3
halfguard / Rap + Hip Hop engineering and production
16
Seti808 / Gearslutz Secondhand Gear Classifieds
10

Forum Jump
Forum Jump