The No.1 Website for Pro Audio
Scarlett 2i2 Ground Loop Noise
Old 1 week ago
  #1
Here for the gear
 

Scarlett 2i2 Ground Loop Noise

Hello Guys,

I have been using Scarlett 2i2 Audio Interface, and when I turn on 48V there is this annoying noise which I believe is a Ground Loop. When I unplug the power cable from the laptop the noise goes away. And when I connect it to an iMac also the problem is there.

I have contacted Focusrite about this issue and they suggested various remedies which haven't worked and all my friends who have been using this Audio Interface have had the same issue.

FYI I have tested this with several power sockets in several houses, and specially I had this issue when I was in Sri Lanka, and now I live in the UK and the problem is still there.

Any of you guys had the same issue?

Any suggestions?

Thanks
πŸ“ Reply
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
πŸ–¨οΈ Show Printable Version
βœ‰οΈ Email this Page
πŸ” Search thread
♾️ Similar Threads
πŸŽ™οΈ View mentioned gear