The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
MainStage 2 - Cloning - Issues
Old 4 weeks ago
Here for the gear

MainStage 2 - Cloning - Issues

This is my first post, so please forgive me if it is in the wrong place or something is not up to par. I searched pretty extensively to find this particular problem to no avail.

Long time MainStage 2 user here. Years of zero issues live on stage.

As I've had the need for more and more complex concerts for multiple bands, I've run into some strange cloning issues. On my cloned drive if I use MainStage 2 without 3rd party plugins everything works fine. Sounds like a simple question, I'm about to ask, but here's where it gets weird. On the same cloned drive, I can start a new concert and use all 3rd party plugins fine as well. I can't however open any of my previous existing concerts that used 3rd party plugins without a MainStage crash. Kontakt 5 player is one of the culprits, as well as Blue Arp and possibly DDMF.

As I said before, I can add kontakt 5 new, even multiple instances, and problems. Seeing as I have massive complex concerts that us lots of aliases, Recreating all of these would be a daunting task with huge amount of man hours wasted. Is there something I'm missing here?

Any help or expertise is greatly appreciated.

Extra info: If I disable enough plugins, I can eventually open "most" of the concerts. They are just unusable to me in that state. May help to troubleshoot though. Also all plugins show as "verified" in plugin manager and work fine when used as a new instance.

Gear used:
2012 Mac Mini Quad Core i7 16G ram
Internal HDD - 1TB Toshiba Fusion
USB Ext. Clone drive - OWC 1TB SSD
Mainstage Ver. 2.1.3 (416.81) (64-bit)
Kontakt Player Ver.
Old 3 weeks ago
Here for the gear

Solved it

After a deactivating multiple plugins, I could successfully open the corrupt.
concerts. Of course they were unusable, but at least i could troubleshoot them. The behavior I saw led me to believe it was a 64bit / 32bit problem. Didn't make sense at first. But once I looked at the info of the MainStage App (right click or control click - get info) , I noticed the "Open in 32 bit mode" check box was checked.

Not sure why the clone drive did this but, for some reason it defaulted MainStage opening in 32 mode. I should have picked up on it earlier because I also wasn't seeing the "32 Lives" (A program to allow 32 plugins work in a 64 bit architecture) symbol up by the volume icon.

This has to be the most bizarre thing I've seen in a while. The clone seems identical in every other than this check box. I'm sure some Mac expert somewhere, knows why. But I'm happy. Problem solved.

Hope this info helps people who use MainStage 2 and have cloning issues. I Believe MainStage 3 is 64 bit only, so it shouldn't be an issue with that version.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump