The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Logic Pro system overload
Old 2nd June 2007
  #1
Gear Maniac
 
G-lay's Avatar
Logic Pro system overload

Hey there

I'm on a MacBook Pro 2.16 coreduo with LogivPro 7.2 running through a digi002R...
I have my sample buffersize on 1024 and still i get a "system overload" message ocasionnaly, don't have that many plug's etc..

How can I fix this ?

cheers

G-lay
Old 2nd June 2007
  #2
Moderator
 
matt thomas's Avatar
might need a faster hard drive, are you recording on your internal drive by any chance?

narco
Old 2nd June 2007
  #3
Gear Head
 
Tony Montana's Avatar
 

I'm getting a similar problem with a Powermac 2.7 and Logic + Fireface 800. Every so often I get a 'Coreaudio overload' message and I'm not even running that many plugins!

I'm recording to the internal drive by the way. Is this bad?
Old 2nd June 2007
  #4
There could be several factors. A faster hard drive might be one, but not likely unless you're running many tracks.

I'm inclined to blame the 002R driver which is noriously bad.

Tell us more about your song, tracks, AUs, instruments, etc.

There are also a couple of things you can do to tweak your system and Logic but mostly it's just a couple of %, not a lot.
Old 2nd June 2007
  #5
Quote:
Originally Posted by Tony Montana View Post
I'm getting a similar problem with a Powermac 2.7 and Logic + Fireface 800. Every so often I get a 'Coreaudio overload' message and I'm not even running that many plugins!

I'm recording to the internal drive by the way. Is this bad?
Not necessarily but I would always recommend having a separate audio drive. Keep your audio and samples on the external drive (or extra drive). 7200 RPM is fine.

Here are some possible things you could check out
-What buffer size are you using? At 256 there should be no problems, but if you still get these error messages you need to look further of course. As I said there are several ways of tweaking your Mac and Logic to increase performance.

-It might be one AU instrument causing a problem, try freezing it. SampleTank can cause this problem for instance.

-Also move your active track to an audio track not an audio instrument track when in playback. That greatly reduces CPU load as it needn't be ready at all times.

-Install the latest Pro Application Support package from Apple.

-Disable Journaling on your audio hard drive. This can increase track count in the area of 20%. Open Disk Utility, choose your audio disk. Hold down the Option key if the Journaling button is greyed-out. This doesn't apply if you're running ProTools AFAIK.

-Turn off Anti-Aliased text in Logic. Logic Pro>Preferences>Display>Anti-aliased text

-Always set processor speed to maximum if possible (depends on your type of Mac) (System>Energy Saving)

-Have as much free space available on all hard disks - minimum of 2 Gb, preferably about 5-10% of your total hard disk space should be free

-Put as much RAM as possible in your Mac, at least 2 Gb in matched pairs (can increase performance up to 5%)

-While OS X doesn't require defragging as such it can benefit from some optimizing. Use Disk Utility and OnyX to clean up.

-I/O Buffer Size. The smaller the buffer the lower latency you get but also more of a system hit performance wise. Quality sound cards and drivers can use a buffer size of 256 down to 32 without any problems.

-Process Buffer Range (Logic Pro>Preferences>Audio>Drivers>Process Buffer Range). Less interal buffer range means more CPU hit but less internal latency and the other way around.

-24 bit recording. I recommend turning 24 bit recording on, but disabling it (16 bits) will increase performance.

-Plug-in delay compensation (PDC). The Off setting provides the best system performance whille All demands the most performance

-Don't use Widgets. Don't even activate them in that session. Once activated they're in the background for the rest of the session (until you restart the computer).

-Turn off alams in iCal. Open iCal: Preferences>Advanced: Turn off alarms when iCal is not active

-If the problem with overloads still persist try freezing and de-freezing the tracks one at a time and see if any track/plug-in/instrument is causing the problem

-And of course need I say: normally you should update your system software, your Logic Pro app, your sound card driver software, turn off any irrelevant software running in the background etc.
Old 2nd June 2007
  #6
Gear Addict
 
drycounty's Avatar
 

Quote:
Originally Posted by Tony Montana View Post
I'm getting a similar problem with a Powermac 2.7 and Logic + Fireface 800. Every so often I get a 'Coreaudio overload' message and I'm not even running that many plugins!

I'm recording to the internal drive by the way. Is this bad?

yes, this is bad -- get another internal to fill up drive bay #2 and use this solely for capturing audio. I'm sure someone else can explain why it's bad better than me, but you don't want to have large (i.e. long blocks of) uncompressed audio files milling around on the same drive where smaller system files exist.
Old 2nd June 2007
  #7
Moderator
 
matt thomas's Avatar
Quote:
Originally Posted by Lagerfeldt View Post
There could be several factors. A faster hard drive might be one, but not likely unless you're running many tracks.
.

good advice there from lager, but the first guy did say he was on a laptop so, it would be worse in this situation. I actually record alot of my professional studio stuff to my internal drive, usually cos I forget to set a recording path, once it starts hiccuping I can just copy it to my external drive for better results.

some plugins use alot of power so only a few instaces will hurt (relatively) like space designer for instance

narco
Old 3rd June 2007
  #8
Lives for gear
 
mersisblue's Avatar
 

Lakger might have said this already

but put the buffer to small in preferences

UAD plugins will cause this smetimes

and how much ram do you have ?

Defrag / optimized the HD ?
Old 3rd June 2007
  #9
Gear Head
 
Tony Montana's Avatar
 

Thanks for the tips guys, I will check my system.



By the way, I have 4 gigs of RAM so I don't think that's the problem.

The current buffer size is 512 in Logic.

I currently have an external Lacie hard drive for backup. Maybe I should get another for recording.

One other problem it could be is that I'm recording at 96KHZ. Perhaps my system can't cope, although it should the money I spent on it!
Old 5th June 2007
  #10
Gear Maniac
 
G-lay's Avatar
Thanks for all the reply's !!
I have 2G of RAM, buffer is on 1014, but i wasa on 512, and had the same problem then.
Sometimes I'm up to 16 instrumenttracks, 5 audio tracks, eq's Sculpture 1 or 2 ultrabeat 1 or 2...
But I mostley happens when I just opend Logic, like it has to "wake up" or something like that... oftens after a couple of times it works fine, but it's an anoying problem..

cheers

G-lay
Old 5th June 2007
  #11
Gear Maniac
 
G-lay's Avatar
ow... and I work from a WD-external harddrive 250Gb
maybe this can bring any light on the problem

G-lay
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump