The No.1 Website for Pro Audio
Huge latency issues on the latest 1903 Windows release - SOLVED
Old 27th July 2019
  #271
Lives for gear
 
daskeladden's Avatar
 

Looks like the new Cumulative Update KB4505903 OS build 18362.267 fixed most of the spikes for me. It's out now!
Ran first a 11 minutes test restarted pc and ran a test for 15 min in Latencymon with with "no" spikes. Maybe not as good as 1809 build but very close to that
Old 27th July 2019
  #272
Lives for gear
 
orange's Avatar
 

Quote:
Originally Posted by daskeladden View Post
Looks like the new Cumulative Update KB4505903 OS build 18362.267 fixed most of the spikes for me. It's out now!
Ran first a 11 minutes test restarted pc and ran a test for 15 min in Latencymon with with "no" spikes. Maybe not as good as 1809 build but very close to that
thanks for the heads up

just downloaded and ran a quick 10min latencymon.....looking good so far.

nothing in the change log of course

@ Psychlist1972 can you confirm if this has the 'fix' ?
Old 27th July 2019
  #273
Lives for gear
 
daskeladden's Avatar
 

Ran Latencymon for the third time:
Attached Thumbnails
Huge latency issues on the latest 1903 Windows release - SOLVED-latencymon.jpg  
Old 28th July 2019
  #274
Quote:
Originally Posted by daskeladden View Post
Looks like the new Cumulative Update KB4505903 OS build 18362.267 fixed most of the spikes for me. It's out now!
Ran first a 11 minutes test restarted pc and ran a test for 15 min in Latencymon with with "no" spikes. Maybe not as good as 1809 build but very close to that
That's the KB (KB4505903) with the DPC latency regression fix. Haven't yet seen it in my own non-Insider WU pipeline, so it may be rolling out slowly.

It was initially bumped to Monday evening, which was why I didn't post about it. Now I see it was pulled back to this past Friday.

Pete
Old 28th July 2019
  #275
Here's where you can find the stand-alone installer for your system. Only do this if you really want the fix and do not yet see it in Windows Update.

http://www.catalog.update.microsoft....px?q=KB4505903

Pete
Old 28th July 2019
  #276
Lives for gear
 
orange's Avatar
 

mine came as part of WU

I ran latencymon for an hour with no spikes. I'm gonna call this fixed for now.

Lesson learned on the updates though, I'm going to be much more reluctant to install in future.
Old 28th July 2019
  #277
Gear Maniac
 
doughnuts's Avatar
 

Quote:
Originally Posted by Psychlist1972 View Post
Here's where you can find the stand-alone installer for your system. Only do this if you really want the fix and do not yet see it in Windows Update.

http://www.catalog.update.microsoft....px?q=KB4505903

Pete
Hi Pete, now thqat the issue appears to be fixed where can i download the Media Creation Tool of this latest version of 1903? my PC is offline but i can download the image to my laptop, burn to a DVD and install onto my offline audio PC that way.
thanks for your help
Old 28th July 2019
  #278
Gear Head
 

KB4505903 has been a massive improvement for me here.
was getting spikes up around 1800us and now the new max is 130us.

also noticed my Tascam UH-7000 interface no longer spikes constantly @ 300us when on.. it doesn't add anything now over what windows does re DPC.

just hope now that the mouse lag i've been experiencing since 1903 has been fixed too. I saw a lot of reports across the net so i wasn't alone.

also want to thank the thread starter and Pete for his participation...
helped keep me sane..
Old 28th July 2019
  #279
Lives for gear
This is such a great demonstration of Microsoft's commitment to its pro users. Truly, thank you so much Pete for being with us and keeping us informed, makes me even more confident that my switch back to Windows from macOS this year is the right move!
Old 28th July 2019
  #280
Gear Head
 

Absolutely! Thanks for your commitment Pete.
Old 28th July 2019
  #281
Lives for gear
Here's an article on fixing high DPC Latency in Windows 10...any comments or suggestions as to its utility ?

https://appuals.com/fix-high-dpc-latency-on-windows-10/

Sweetwater has some input also (but not Win 10 specific): https://www.sweetwater.com/sweetcare...atency-issues/

I know LatencyMon works well in Win 10, but how about the older DPC Latency Checker Tool, which dates back to the XP/W7 era ? https://www.thesycon.de/eng/latency_check.shtml

Last edited by studer58; 28th July 2019 at 02:32 PM..
Old 28th July 2019
  #282
Lives for gear
Pete's presence and always-positive approach to the requirements of audio users, music makers, pro and hobbyist music production folks is a shining template example of responsive corporate behaviour.

While we should be under no illusion that ''our class of user" represents any significant part of Microsoft's user-base (from the point of view of that company's perception) , the very fact that our concerns have made it on-board to the trouble-shooting and resolution level in this instance is no doubt due to Pete's steady persistence in raising and maintaining priority at MS on our behalf.

Undoubtedly there will be ups and downs in future too...the dread of updates and broken drivers, for not much apparent gain... and often tied to some drop in efficiency...won't go away in a hurry.

However if this user group can maintain at least some level of significance on MS's troubleshooting landscape, due to Pete's agency...then we have a great deal to be thankful for...and owe him much thanks too !
Old 28th July 2019
  #283
Gear Head
 
jjnssn's Avatar
 

Quote:
Originally Posted by daskeladden View Post
Looks like the new Cumulative Update KB4505903 OS build 18362.267 fixed most of the spikes for me. It's out now!
Ran first a 11 minutes test restarted pc and ran a test for 15 min in Latencymon with with "no" spikes. Maybe not as good as 1809 build but very close to that
Quote:
Originally Posted by daskeladden View Post
Did not solve the issue but worth a try. I'm downloading a new Cumulative Update from Windows now let hope that solve it
Hey daskeladden,
Thank you for starting this thread and following it through. I have been able to record two consecutive 20 min session in protools with no failures with the Latest KB in 1903.

Pete thank you also. I am grateful for your and the folks at MS persistence on this issue.

Cheers!
J
Old 28th July 2019
  #284
Quote:
Originally Posted by studer58 View Post
Here's an article on fixing high DPC Latency in Windows 10...any comments or suggestions as to its utility ?

https://appuals.com/fix-high-dpc-latency-on-windows-10/

Sweetwater has some input also (but not Win 10 specific): https://www.sweetwater.com/sweetcare...atency-issues/

I know LatencyMon works well in Win 10, but how about the older DPC Latency Checker Tool, which dates back to the XP/W7 era ? https://www.thesycon.de/eng/latency_check.shtml
The power options make sense. Most of the rest, especially disabling built-in firewall/av/etc. doesn't. There are very few tweaks that apply universally. SO much has to do with your specific audio interface, video card, motherboard, etc.

I've contacted a number of people/companies about their outdated tweaking guides. They're not in a hurry to change them :(

Pete
Old 28th July 2019
  #285
Thanks all.

Glad to hear this fix is getting positive results!

Pete
Old 28th July 2019
  #286
Gear Maniac
 
sosho's Avatar
Quote:
Originally Posted by daskeladden View Post
Looks like the new Cumulative Update KB4505903 OS build 18362.267 fixed most of the spikes for me. It's out now!
Ran first a 11 minutes test restarted pc and ran a test for 15 min in Latencymon with with "no" spikes. Maybe not as good as 1809 build but very close to that
Confirmed , just tried it on my Office PC and C2D notebook so far
Old 29th July 2019
  #287
Lives for gear
 
Finnish's Avatar
 

Really good stuff, now my desktop and laptop audio machines are finally free of peaks

I ran the test for an hour on both setups and all green, all good. It's a good day to start recording the vocals on my solo album
Old 29th July 2019
  #288
Win 10 back to near perfect here again!
Thanks for the patch,
Norm
Old 29th July 2019
  #289
Here for the gear
 

No Joy in Mudville

I have read with great interest for many years the informed tips and opinions on this forum but up till now never felt i needed to post anything....That most people have found the latest update to have solved their problems is great.. unfortunately the latest update [Kb 4505903]has not solved my latency spikes.
In fact i noticed it with the 1809 build but it was a momentary "drop out" so i figure i would update to 1903....much worse random spikes crashing Ableton in the bargain now!...is anybody else experiencing this?and is there another patch/update being worked on?.

My computer is a Dell xps 8930 intel 8700[non k]speed step off,regular DAW power scheme 16gb of ram with a Nvidia 1050 ti Video card.. less than a month old... N.I. audio 6 usb for sound, all drivers updated....Any info./help in this matter would be greatly appreciated. thanks.
Old 29th July 2019
  #290
Lives for gear
 
orange's Avatar
 

Quote:
Originally Posted by SoundPainter View Post
I have read with great interest for many years the informed tips and opinions on this forum but up till now never felt i needed to post anything....That most people have found the latest update to have solved their problems is great.. unfortunately the latest update [Kb 4505903]has not solved my latency spikes.
FWIW this fix is for a very specific issue that 1903 introduced, which was spikes related to ntoskrnl.exe- it's not intended as a fix for all latency spikes
Old 29th July 2019
  #291
Here for the gear
 

Thanks for that, it is exactly the same culprit as all others have experienced causing the random spikes... Ntoskrnl.exe
Old 29th July 2019
  #292
Lives for gear
 
daskeladden's Avatar
 

Quote:
Originally Posted by SoundPainter View Post
Thanks for that, it is exactly the same culprit as all others have experienced causing the random spikes... Ntoskrnl.exe
If you also had the spikes on the 1809 build it is caused by something else than the specific issue in this thread. Just out of curiocity can you post a screenshot of Latencymon after it's been running for 10 minutes, of this:
Old 29th July 2019
  #293
Here for the gear
 

This is what i got today....
https://www.gearslutz.com/board/atta...000=1564398984 Yes i see Nvidia and intel graphics are front and center in these shots, most of the time it is ntoskrnl.exe at the top...
Attached Thumbnails
Huge latency issues on the latest 1903 Windows release - SOLVED-10-min.jpg   Huge latency issues on the latest 1903 Windows release - SOLVED-19-min.jpg   Huge latency issues on the latest 1903 Windows release - SOLVED-drivers-19-min.jpg   Huge latency issues on the latest 1903 Windows release - SOLVED-drivers-19-min.jpg  
Old 29th July 2019
  #294
Lives for gear
Quote:
Originally Posted by [email protected] View Post
Win 10 back to near perfect here again!
Thanks for the patch,
Norm
Is it still somewhat premature, or would this resolution now suggest it's a green light to update from 1809 to 1903 ?
Old 29th July 2019
  #295
Lives for gear
 
orange's Avatar
 

Quote:
Originally Posted by studer58 View Post
Is it still somewhat premature, or would this resolution now suggest it's a green light to update from 1809 to 1903 ?
Is there a reason you need to update ?
Old 29th July 2019
  #296
Lives for gear
 
daskeladden's Avatar
 

Are those two test from the same day? Why are they so different? That first test looks pretty decent. Try and disable the external graphic card from device manager and use the internal graphic to see if the issue persists (take a new Latencymon test). Be sure that your Intel CPU graphic driver is updated. This is just the beginning of the elimination method.
Also try and install the intel Driver and Support assistant. Then run it to see if your chipset is out of date:
https://www.intel.com/content/www/us...rt/detect.html

I take for granted that your external graphic card driver is updated.



Quote:
Originally Posted by studer58 View Post
Is it still somewhat premature, or would this resolution now suggest it's a green light to update from 1809 to 1903 ?
SoundPainter has another issue. You can safely update to 1903 when it comes to latency issues
Old 29th July 2019
  #297
Quote:
Originally Posted by studer58 View Post
Is it still somewhat premature, or would this resolution now suggest it's a green light to update from 1809 to 1903 ?
1903 runs fine here with Sequoia 15.
N.
Old 29th July 2019
  #298
Lives for gear
Quote:
Originally Posted by orange View Post
Is there a reason you need to update ?
No particular need, unless it somehow runs more efficiently or has lower innate latencies or other advantages for either audio recording or video editing than 1809....since these are the 2 main roles I use this computer for.
Old 29th July 2019
  #299
Lives for gear
 
orange's Avatar
 

Quote:
Originally Posted by studer58 View Post
No particular need, unless it somehow runs more efficiently or has lower innate latencies or other advantages for either audio recording or video editing than 1809....since these are the 2 main roles I use this computer for.
1903 is almost certainly not better than 1809 so I would delay as long as possible.
Old 29th July 2019
  #300
Lives for gear
Quote:
Originally Posted by orange View Post
1903 is almost certainly not better than 1809 so I would delay as long as possible.
So the latest repair (KB4505903) is intended only for a problem which became apparent with 1903, and wasn't there in 1809 ?
๐Ÿ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 4589 views: 575794
Avatar for stixstudios
stixstudios 20th May 2020
replies: 179 views: 45745
Avatar for Mercado_Negro
Mercado_Negro 22nd December 2011
replies: 775 views: 162276
Avatar for 360studios15
360studios15 3 days ago
replies: 93 views: 5605
Avatar for dapz
dapz 5 days ago
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
๐Ÿ–จ๏ธ Show Printable Version
โœ‰๏ธ Email this Page
๐Ÿ” Search thread
๐ŸŽ™๏ธ View mentioned gear
Forum Jump
Forum Jump