The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Loud electrical buzz coming from Apollo Twin USB Audio Interfaces
Old 4 days ago
  #1
Here for the gear
 

Thread Starter
Loud electrical buzz coming from Apollo Twin USB

Hi all,

Looked through the forum and couldn't find this particular issue. Just bought an Apollo Twin USB and have it going directly into a Blade Stealth USB 3. I'm getting this ridiculously loud buzz. Looking deeper it seems the noise will shut off I unplug the USB cable from either the IO or the notebook. It's a brand new cable and the one UAD provides with the Apollo Twin.

Any insights into why this is happening and how I can fix?
Old 4 days ago
  #2
Here for the gear
 

Thread Starter
Update - it seems it's coming from the charging cable being plugged in. It's 100% clean when I don't have any power feeding to the computer. May be a grounding issue and can try to lift the ground, but am scratching my head if that's really a long term solution. Any recommendations?
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump