The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Need help please! Mbox Pro 3 won't connect to my pc anymore... Control Surfaces
Old 3rd April 2017
  #1
Here for the gear
 

Need help please! Mbox Pro 3 won't connect to my pc anymore...

Hi everyone, I'm Jonathan, ntmu!

I have been having problems with my Mbox Pro 3 interface for a while now. I can't get it to connect to the PC anymore. When I fire on the interface, before turning on the PC, the LEDs are solid green and blue... no flashing. Then I turn on the PC and nothing happens. The interface will not appear in the Device Manager and will appear as ''Hardware Not Connected Not Streaming'' in the Mbox Pro Control Panel.

The interface is connected to a PCIE extension card. The card is qualified by Avid of course and is the following :

Startech 3 Port 1394 PCI Express FireWire Card
Part Number: PEX1394B3 (RoHS compliant)
Bus type: PCI Express x1


My PC is running Windows 10, latest updates.

The build is the following :

CPU - Core i7 6800 @ 4Ghz
Motherboard - Asus X99-A II
RAM - 32GB DDR4 Corsair Vengeance
GPU - Gigabyte GeForce GTX 750 Ti OC
OS Drive - Crucial 750GB SSD
Data Drive - WD 750GB HDD / Kingston 240GB SSD
Power Supply - Corsair Platinum 750W
OS - Windows 10 Home 64Bit




For my DAW, I use FL Studio, newest version, 64Bit.




I have tried everything I thought of... Re-installing the drivers, wiping the drivers clean and installing them again, re-installing the firewire adapter drivers... Nothing worked. It was working fine when I first got the PC but now I can't do nothing with it. What is funny is that when I plug it into my Macbook Pro, it works fine just as it use to on the PC... So please, if someone knows something that can help me, I would really appreciate it.

Thank you,

Jonathan
Old 3rd April 2017
  #2
Deleted 3cb98a6
Guest
Always first boot p.c and only then turn on interface. The way you describe it
, it is bound to go wrong
Try a different usb or firewire port aswell.

For windows 10 in combination with firewire it is very advisable to install the firewire legacy drivers for your pci card. Downloadable for free. Install legacy then Check system >1394drivers and >manually select the legacy drivers from the list to drive you card.

Goodluck
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump