The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Focusrite Scarlett 18i20 gen 2 driver issue? Audio Interfaces
Old 15th February 2017
  #1
Here for the gear
 

Focusrite Scarlett 18i20 gen 2 driver issue?

Hey people, I've just got myself one of these nice shiny red things!

Just one problem, though: the drivers won't install on my windows 7 machine.

I run the .exe, and it install the 'control' program, but when trying to install the actual drivers, it comes up with the message that 'these drivers are unsigned.' It gives me option to install them anyway, and then the message pops up again. After this second popup, I get a message saying that the drivers are unsigned, but there's no option to install anyway.

I've gone through the trouble shooting steps on the website, including making sure that the windows 7 patch is installed - it appears to be, so I don't really know where to go from here, other than doing a complete reinstall of the OS.

For some reason, it works on my laptop, which is running Windows 10, so that lead me to believe that it was an OS compatibility issue, but on the focusrite website, it's listed as being Win 7 compatible.

So, any possible solutions before I attempt a reinstall?
Old 15th February 2017
  #2
Lives for gear
 
fireberd's Avatar
Have you contacted Focusrite? They are very good (at least in dealings I've had with them) on responding and helping.

I have a 6i6 2nd generation but only Win 10 so I can't test that on another OS.
Old 16th February 2017
  #3
Gear Maniac
 

Hi Encarcerous,

Sorry to hear that you're having some problems. The issue that you've mentioned is due to the Focusrite driver needing a specific Windows Update to be installed on some Windows 7 machines, please could you try following the steps in this article from our Help Centre: https://support.focusrite.com/hc/en-...dows-7-machine

If this doesn't work please feel free to contact us directly and we can investigate this further for you: https://support.focusrite.com/hc/en-gb/requests/new

Best regards,
Jack // Focusrite Technical Support
Old 16th February 2017
  #4
Here for the gear
 

Thanks for the replies, guys

Yeah, I've tried contacting focusrite's support directly, but I haven't received a reply yet.

I ended up decided that it was probably time for a system wipe anyway, so I'm reinstalling Windows, but I just noticed that there was a prerequisite for the update that you mentioned, jack, so after I'm done with the reinstall, I'll see what happens if I follow that.

Edit: it still doesn't want to install, due to the same reason. This is a tad annoying.
Top Mentioned Products
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump