The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Anybody running Windows 10 with a Mackie 1200f?
Old 22nd November 2016
Here for the gear
Stevenage's Avatar

Anybody running Windows 10 with a Mackie 1200f?

Hi Everyone, I'm looking to move from Windows Vista. I have been sticking with it so long because I love my 1200f with its 12 mic pres and I like the way it sounds. Also, a lot of software just isn't supported with Vista anymore.

I have heard that Windows 7 works but I would like to get 10 so I don't have to do this again in the near future.

So has anybody tried their 1200f with Windows 10?

Above link to latest driver.

Old 22nd November 2016
Lives for gear


honestly I'm quite skeptic, you'll manage to run it at Window 10.. It's really old driver for Firewire interfaces based on Echo audio chipset.
Even with Windows 7 it won't be a smooth sailing and might require to enable special system mode with unsigned drivers and possibly some additional fiddling.

I don't have F-series interface, but Mackie used several FW chipset vendors over the years, each driver for particular board is based at respective OEM driver.. and only compatible with Windows 8.1, 10 and the supported ones are by TC Applied Technologies.
This is also reflected at their updated compatibility chart, where F series isn't even listed.
Onyx Driver Compatibility | Mackie

So I'd probably stick with Win 7, until you swap the interface.

Old 22nd November 2016
Lives for gear

Get away from Mackie and its drivers...nothing but trouble.
Old 23rd November 2016
Here for the gear
Stevenage's Avatar

Originally Posted by FoxMulderFBI View Post
Get away from Mackie and its drivers...nothing but trouble.
I know! Find me 12 pres that sound that good though. Antelope? I don't have that kind of money to spend.
Old 13th January 2017
Here for the gear
Stevenage's Avatar

Update: So I bought a nice used PC and did a fresh install of Windows 7. For the life of me I can't get it to work properly. The drivers load and the computer sees it but as soon as I try to access its settings through another program like Reaper or even Windows it locks up. So next I hooked up my Focusrite pro40 and it works fine.

I have gone back and tried everything I could but it never improved. At least I can adjust the settings with the Mackie F series software. I'm bummed but at least I can use the adat out to add to the Focusrite.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump