The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Upgrade from Tascam FW-1082 to FW-1084 problems Keyboard Synthesizers
Old 3rd August 2016
  #1
Upgrade from Tascam FW-1082 to FW-1084 problems

[EDIT ...OOOOPS, I mean FW-1884, not FW-1084 in the title, and can't seem to change it]

[2nd EDIT; See my post as of 8/18/2016] I got the FW-1884 working somewhat ok with my studio laptop, it appears that there are more than one driver version 1.80...one for each of Tascams FW line-up (FW-1082, FW-1884 interface/controllers, & the FW-1804 rack unit).

Hello,

I bought a used Tascam FW-1884 from eBay, said to be fully functional to upgrade my current lesser model Tascam FW-1082 which works great on my Lenovo ThinkStation D-20 (Win 7 64 bit).

When I swap between the 2 Tascam's (after my FW-1082 has been working fine) I power down, connect this FW-1884, power up, and the firewire light on the 1884 typically won't light up, though it did once or twice at 1st, it won't connect to PC, therefore cannot control Cubase without connecting.

I'm using the latest driver from Tascam (version 1.80 which works great on my FW-1082 with Win 7 64 bit) My Lenovo's Firewire port has a Texas Instruments chip, and is set to "legacy" Aside from the firewire light not light up on the FW-1884, (and assuming I CAN get that light going again) isn't the FW-1884 unit supposed to just work after the lesser FW-1802 has been connected & working fine? Or is there some procedure that has to be done when swapping/upgrading from a FW-1082 to a higher model FW-1884? Like a driver delete & reinstall? When I swap my smaller FW-1082 BACK again, it still works great every time.

Other things is that when pressing the Tascam power button to 'on', sometimes every single light on it lights up, and stays lit, which I believe is not normal. When I press 'off' then 'on' again, I can get it to normal with only a handful of lights on. And not being familiar with this FW-1884, (which I know I'll have to read the manual) there are several extra buttons that I don't know what they're for, but they don't seem to respond...like all the extra buttons to the left of this board for example. Maybe the board needs to connect to a computer 1st?

Anyone ever upgrade from the lesser FW-1082, to the FW-1884? Did it just plug in and work? Did you have to do some procedure?

Last edited by Steve Fogal; 18th August 2016 at 04:27 PM.. Reason: correction/bought a FW-1884, not 1084
Old 6th August 2016
  #2
So, in hopes that someone with experience in using both a Tascam FW-1082 and a FW-1884 is seeing this post over the next days ahead...

Has anyone upgraded, or downgraded from one of these units to the other? Did you need to uninstall/reinstall the Tascam driver, or did it just work by plugging them in, one at a time, back & fourth, using the same driver install? In other words, could these units just be swapped?

Of course this important part, last weekend when I had any time to fool with this, I was having issues with this newer Tascam FW-1884's Firewire light, not lighting up consistently, while my existing FW-1082's Firewire light comes on every time...and I'm using the same Firewire port on my PC (which is set to 'legacy'). With that FW light issue, I'm thinking there must be something wrong with this FW-1884 unit I just got.

I had sent a detailed note to this eBay seller, about my issues, and days later, the response I got was "how can I help you today?" WTF??? I just sent him another note, asking if he even read my note at all, if he's had personal experience with the FW-1884 he just sold me. I'd think he would of at least said that in his reply. The new note I just sent him, I've asked for a refund if it's not as he described, which was "fully functional". I was hoping to gain the extra connections of this FW-1884, the optical digital audio & word clock I/O, which my FW-1082 doesn't have. I'll give it another go over this weekend, but I think this must be DOA on it's Firewire port. I could attempt the driver uninstall/reinstall but I don't see that helping if the Firewire LED doesn't come on.
Old 6th August 2016
  #3
Lives for gear
Did you uninstall the old driver and download and install the driver for the new unit specifically? It doesn't seem like it after reading your post.
Old 6th August 2016
  #4
Quote:
Originally Posted by Alndln View Post
Did you uninstall the old driver and download and install the driver for the new unit specifically? It doesn't seem like it after reading your post.
Hi thanks Alndln, sorry I thought I said... no, I did not uninstall the driver I currently have, and then reinstall it specifically for this FW-1884 yet. Both the Tascam units, FW-1082 & FW-1884 use the same driver version 1.80, which this driver is for, and does work in Win 7 64 bit. I was assuming that simply swapping from my FW-1082, to the FW-1884 would just work. I could try the driver thing, but there's that FW light issue too.

One thing I forgot to mention, is that when the FW-1884's Firewire light initially came on, it showed up in my list of Devices, as would be expected, said FW-1884, in place of the FW-1082. But even at the time the Firelight was actually 'ON' I couldn't get it to actually connect. It was at this point I was wondering if I needed to unsinstall/reinstall the same driver.

When the FW-1884 didn't connect (even with the FW light on), I swapped back to the FW-1082 (worked fine again) then swapped back to the FW-1884, and couldn't get the FW light of the FW-1884 to come back on.

And yes, I made sure both my PC, and the Tacams were powered OFF each time I swapped units.
Old 18th August 2016
  #5
***Update***

This is another one of those times where it may be my own fault. And hopefully this will help as an archive to anyone else who's going from a Tascam FW-1082 to a FW-1884, or visa-versa.

I was apparently mistaken regarding the driver I had been using for the FW-1082, which was driver version 1.80 ... what I actually needed was the driver version for the FW-1884, 'also driver version 1.80'. I had assumed that there was only 'one' driver version 1.80 was for ALL the Tascam's in this FW line-up (FW-1082, FW-1884 interface/controllers, and the rack mount FW-1804). Not so!
I downloaded driver version 1.80 for my FW-1884, and now I have two Tascam 1.80 driver versions installed on the same PC. I use whichever, depending on whether I have the FW-1082, or the FW-1884 plugged in.

I only actually tested this on my home studio laptop PC with Win Vista, and it only has a 4-wire firewire port. This suffers the same issue I had with my FW-1082 using the 4-wire, in that it takes 'forever' to become stable, but when it does, it remains very stable. This is most likely to do with 2 facts... 1) it's a 4-wire Firewire port that has no power of it's own, 2) it's not a Texas Instruments chip either.

Though I went ahead and installed the 1.80 driver version 'specifically for the FW-1884' on my Win 7 Pro main DAW desktop PC, I've not tried this FW-1884 with it yet, but I'm assuming it will work ok. This Win 7 desktop PC does NOT have the issue of waiting for the FW-1082 to become stable after a long while, it has a TI chip and works stable immediately. I can assume the same in using the FW-1884. Hopefully I'm right that it'll work on my main DAW PC too.

So it at least appears that this FW-1884 at least 'works' but can't be sure it's fully functional in every way just yet.

_______________________________________

**follow up*** on 10/20/2016

I actually was googling and found my own thread lol.

Anyway, following up, my Tascam FW-1884 has been working great on my Win 7 64 bit, Cubase PC with the proper 1.8 driver specifically for the FW-1884. As I had said before the 1.8 driver for the FW-1082 I had tried to use is different!

Last edited by Steve Fogal; 20th October 2016 at 09:07 PM..
Old 16th April 2018
  #6
*addition to my old thread for archives in case some one has these older units, I have a discovery to share;

I've discovered something new just last week after all this time. There's a common issue with people using the Tascam FW series units (1884,1082, 1804) getting the them to connect and/or getting the firewire light to come on to be able to use it.

What I've discovered is that if I open the Soft_LCD (some call it scribble strip) 1st, after booting up computer, THEN power up my Tascam FW unit, the firewire light comes on, no 'warm up' needed.

I'm not clear as to why this works, openeing up the Tascam software control panel doesn't do this, but the Soft_LCD does. Looking into what this Soft_LCD is all about, say's that it's basically a display to show what's going on within the Tascam controller/interface. It's supposed to send midi messages back & forth. I'm not clear why or how these messages relate to telling my Tascam FW-1884's firewire light to come on every time (so far), where as several other powering up methods won't at times. I was thinking I may have a firewire connection failure, but this doesn't appear to be the case, but seems more of a software handshake thing.

Anyway, for me this is an very important discovery and I can't find a single mention of this anywhere on the internet after several days of searching archives of Tascam FW posts.
Top Mentioned Products
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump