The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
MIDI triggering on note release
Old 5th July 2016
  #1
Here for the gear
 

MIDI triggering on note release

Hi,

I'm having problems with midi triggering in Cubase 5.

I'm far from an expert, but I know a midi signal is triggered at when a key is pressed and again when it's released, with the release signal triggering the 'decay' of the note.

However, what currently happens is I press a note and see in the control panel that a 'midi in' signal has been registered, but no sound. It's only when I release the note and the second 'midi in' signal is registered that the sound is heard. What's more the sound continues with infinite sustain, and if I press the same note more times, the same number of random notes will be added so I end up with a random chord.

In the Key Editor, quite a few notes are greyed out, like they are being pressed down on the keyboard, but I'm not playing anything and haven't written any notes in.

This appears to happen across all my VST instruments and projects. I'm not at all sure how to tackle it so I would appreciate any help!

Thanks in advance.
Old 5th July 2016
  #2
Gear Guru
 
jwh1192's Avatar
this will at least get you a bump .. sustain pedal controller running backwards ??
Old 5th July 2016
  #3
Here for the gear
 

Quote:
Originally Posted by jwh1192 View Post
this will at least get you a bump .. sustain pedal controller running backwards ??
Thanks for the reply. Sorry but as I said I'm no expert at this - how would I go about fixing that if it is the problem?
Old 6th July 2016
  #4
Caution, the mere mention of being a Cubase 5 user will cause over-zealous fan boys of accusing you of using a crack ... because NO ONE really ever bought it legitimately you know You will soon be pressured to buying the latest very expensive version of Cubase. But you may want to hold out for Cubase version 9, because if you're still using Cubase 8 by then, you'll be tarred and feathered

Seriously, this has never happened to me, and I'm not sure of the fix for this, but what I'd do in the meantime, is check or clear your preferences, or be sure it's set to the defaults in the midi set up sections. Also double check your midi controller for proper sending of midi messages. In my keyboard, I have 2 main options, one will send midi properly out, the other will not (my 'mix' & 'program' modes). Make sure you're sending on a specific midi channel there, and receiving that specific midi channel in Cubase.

Things you can look for in Cubase. Select from the upper left top of the Cubase program while open; File > Preferences > in the drop down menu see/select MIDI Filter, a dialog box will open, press "Defaults" then "Apply" at the bottom. Be sure none of the 16 buttons are highlighted (muted). in 'Default' only the 'SysEx' should have check marks in the upper part of this dialog box, and none of those 16 buttons should be highlighted/muted.

Also look at the upper area of Cubase again, see/select "Devices", a drop down menu will open, select "Device Setup" in which a dialog box will open, see MIDI Port Setup". Make sure something is 'active' in there at the upper right. Also, there are at the top left of this same dialog box, a plus & minus (+/-), if you press "+" it will open a drop down menu. In THIS case, the ONLY thing I use this for, is to set my Tascam FW-1082 audio interface/controller/mixer, so I can use it with Cubase...as a controller/interface of course. I'm not sure this will help you with your problem or not. I have to think it's the Cubase midi preferences thing 1st, or your midi controller isn't sending out proper messages. I don't know about that "backwards pedal" thing, but maybe try disconnecting it temporarily to see if there's any change.
Old 8th July 2016
  #5
Here for the gear
 

Quote:
Originally Posted by Steve Fogal View Post
Caution, the mere mention of being a Cubase 5 user will cause over-zealous fan boys of accusing you of using a crack ... because NO ONE really ever bought it legitimately you know You will soon be pressured to buying the latest very expensive version of Cubase. But you may want to hold out for Cubase version 9, because if you're still using Cubase 8 by then, you'll be tarred and feathered

Seriously, this has never happened to me, and I'm not sure of the fix for this, but what I'd do in the meantime, is check or clear your preferences, or be sure it's set to the defaults in the midi set up sections. Also double check your midi controller for proper sending of midi messages. In my keyboard, I have 2 main options, one will send midi properly out, the other will not (my 'mix' & 'program' modes). Make sure you're sending on a specific midi channel there, and receiving that specific midi channel in Cubase.

Things you can look for in Cubase. Select from the upper left top of the Cubase program while open; File > Preferences > in the drop down menu see/select MIDI Filter, a dialog box will open, press "Defaults" then "Apply" at the bottom. Be sure none of the 16 buttons are highlighted (muted). in 'Default' only the 'SysEx' should have check marks in the upper part of this dialog box, and none of those 16 buttons should be highlighted/muted.

Also look at the upper area of Cubase again, see/select "Devices", a drop down menu will open, select "Device Setup" in which a dialog box will open, see MIDI Port Setup". Make sure something is 'active' in there at the upper right. Also, there are at the top left of this same dialog box, a plus & minus (+/-), if you press "+" it will open a drop down menu. In THIS case, the ONLY thing I use this for, is to set my Tascam FW-1082 audio interface/controller/mixer, so I can use it with Cubase...as a controller/interface of course. I'm not sure this will help you with your problem or not. I have to think it's the Cubase midi preferences thing 1st, or your midi controller isn't sending out proper messages. I don't know about that "backwards pedal" thing, but maybe try disconnecting it temporarily to see if there's any change.
Thanks for you reply. Good news, the problem seems to be resolved. I followed your advice, reset defaults and went through all the midi input options making sure everything was in order, and something worked because it's playing as it should now. Thanks for the help!
Old 9th July 2016
  #6
Quote:
Originally Posted by Ollie5 View Post
Thanks for you reply. Good news, the problem seems to be resolved. I followed your advice, reset defaults and went through all the midi input options making sure everything was in order, and something worked because it's playing as it should now. Thanks for the help!
Glad to hear it
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump