The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Problems with Focusrite Scarlett firmware update?
Old 20th March 2016
  #1
Here for the gear
 

Problems with Focusrite Scarlett firmware update?

Hi guys,

Just wanted to see if anyone else was having similar problems to me with their Scarlett interfaces.

A bit of background:
I bought a Scarlett 18i8 around when Windows 10 came out, and was having problems with the latest stable drivers. Read somewhere I should try the beta drivers, so I did that and it was fine.

Then there was a new MixControl/driver beta update that kinda borked the sample rate switching. It was annoying, but I could live with it if it meant having a working audio interface on W10.

Earlier today, the sample rate switching was failing me completely, disallowing me to open a Pro Tools session, returning errors about how it couldn't switch sample rates (and occasionally blue-screening me).

I looked on the Focusrite website to see there's a pretty fresh version of MixControl/USB2 drivers. The patch notes mentioned improvements in sample rate switching instructions, which I was stoked about!

This leads me to my current problem.

Got the new software, installed it, and when I loaded up MixControl, it told me I needed to update my firmware. Now it just keeps saying "A problem occurred during the firmware update", and closing out. I tried reinstalling MixControl and restarting my comp, with the same result.

Then to see if it was a problem with the unit, I unplugged it and plugged in my 18i20. Same result.

Unfortunately, installing an older version of MixControl returns an error about MixControl being out of date for the hardware I'm using, so as far as I'm aware right now, I don't have a working audio interface :(.


SYSTEM SPECS:
CPU: i7 4790K
GPU: nvidia GTX970
RAM: 2x8GB 1866mHz
SDD: 512GB ADATA SX900
OS: Windows 10 Version 1511 (OS Build 10586.164)


Anybody else having similar problems?
I'm a newbie around here so let me know if I haven't provided enough info. Apologies for the wall of text!
Old 24th March 2016
  #2
Here for the gear
Quote:
Originally Posted by dannybrickwell View Post
Got the new software, installed it, and when I loaded up MixControl, it told me I needed to update my firmware. Now it just keeps saying "A problem occurred during the firmware update", and closing out. I tried reinstalling MixControl and restarting my comp, with the same result.

Then to see if it was a problem with the unit, I unplugged it and plugged in my 18i20. Same result.
I have the Scarlett 18i20 and also just tried to update the firmware after the new version of MixControl was installed... same firmware update failure.
Old 25th March 2016
  #3
I've had the exact same issue with my 18i20. I opened a ticket with Focusrite and they gave me the usual "optimize your PC" thing, which I had already done. After a while I realized it was only occurring at higher sample rates. At 44.1 kHz I have no issues, at 96 it completely crashes, and everything else in between is, well, in between. I've tried using updating the mix control driver as well but had the firmware fail.

I use Studio One and all of these issues seem to have popped up since I upgraded to Studio One v3 and/or Windows 10 (I did both around the same time). I started watching the little CPU performance bar at the bottom and noticed that the pops and sample rate switches were occurring during spikes and at a certain point, if it hit 100% it would basically start flipping out and crash the program.

So now I have an open ticket with Presonus as well. I really don't understand because, like you, my computer should be more than adequate to operate fine regardless of sample rate.
Old 25th March 2016
  #4
Thanks for talking about it here, before I did something stupid, and screwed up my system.
Old 2nd April 2016
  #5
Here for the gear
 

Unfortunately, I didn't see this thread. I'm in the same boat now. Attempted to install most recent beta yesterday and now I am stuck (firmware update failed). Do you have any news?

I saw that Focusrite beta website only supports up to Windows 8.1. Did anybody try to fix firmware update on an older Windows? It might work again on Windows 10 afterwards. Just a thought. Or on a Mac?
Old 3rd April 2016
  #6
Here for the gear
 

I was able to revert to last working usb driver, version of mixcontrol and firmware (previsous beta version). To do the firmwire update this time I plugged the scarlett directly into the usb port on my laptop (and not thru hub). That made a difference. I am still on Windows 10. I didn't try other OS. Should I try to update to most recent beta again, this time while by plugging usb in directly? I am little hesitant after all this.
Old 27th May 2016
  #7
Here for the gear
 
LilCaucasianBoy's Avatar
 

This is a weird one, but I managed to get it working by accepting the update AS SOON as the prompt came up. I noticed that the MixControl opens for a couple of seconds and then closes (as in saying no hardware connected) while the prompt is up. If you manage to accept the prompt before the the mixcontrol changes in the background, it will work.
Old 6th June 2016
  #8
Here for the gear
 

I had this problem too - was unable to update the firmware after installing v1.9b12. I ended up finding an earlier version 1.9b4 on the beta website, and installing that fixed the PT problems, and it doesn't require a firmware upgrade. Your mileage may vary. The link is http://beta.focusrite.com/file.php?id=1124
Old 4th August 2017
  #9
Here for the gear
 

I need help :( my 8i6 will not allow the upgrade to happen. It just fails every time! The firmware won't even try to download.
Old 4th August 2017
  #10
Here for the gear
 

You need to use the latest beta drivers for your device.

Focusrite / Novation Beta Testing :: Releases

Cheers,
Electrobop
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump